Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem with the rest api
 
bibliotec
Jr. Member
 
Total Posts:  10
Joined:  2009-11-06
 

I’m trying to work with the Rest API magento but I find the way I followed the wiki but I fail routes, I’m using these:

$ callbackUrl = ‘http://www.xxxx.com/tiendademo/index.php/admin/’;
$ temporaryCredentialsRequestUrl = ‘http://www.xxxx.com/tiendademo/index.php/oauth/initiate?oauth_callback =’. urlencode ($ callbackUrl);
$ adminAuthorizationUrl = ‘http://www.xxxx.com/tiendademo/index.php/admin/oauth_authorize’;
$ accessTokenRequestUrl = ‘http://www.xxxx.com/tiendademo/index.php/oauth/token’;
$ apiUrl = ‘http://www.xxxx.com/tiendademo/index.php/api/rest’;

and also these:

$ callbackUrl = “http://www.xxxx.com/tiendademo/oauth_customer.php”;
$ temporaryCredentialsRequestUrl = “http://www.xxxx.com/tiendademo/oauth/initiate?oauth_callback =”. urlencode ($ callbackUrl);
$ adminAuthorizationUrl = ‘http://www.xxxx.com/tiendademo/oauth/authorize’;
$ accessTokenRequestUrl = ‘http://www.xxxx.com/tiendademo/oauth/token’;
$ apiUrl = ‘http://www.xxxx.com/tiendademo/api/rest’;

And do not work even I have searched the archives and are not in the directory, and i dont know whats wrong.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top