Magento Forum

   
Products not showing and SSH reindex errors after import. 
 
Yanith
Jr. Member
 
Total Posts:  22
Joined:  2011-09-21
 

I’ve spent a couple of days trying to figure you why the import works but, for the products to work i have to go and open every product and save it again to make it available on the catalog.

I created the CSV and imported using System > Import/Export > Import

Uploaded my file, checked the data, clicked the import and everything runs smooth (except images but that is another story).

After that I would get the re-index message, I would run the indexes and they work fine in magento.  however I notice, that for the products to be active I had to go into the product and save it again. at that point the database entry would go from magento_catalog_product_entity to magento_catalog_product_flat_1. If I don’t manually go and save them they will not move.

After that I tried to run the reindex using terminal
so I navigate to the site shell folder and ran “php -f indexer.php reindex all”

This game me some clues. an old custom calculator build by someone else was trying to access the app/mage.php

PHP Fatal error:  require_once(): Failed opening required 'app/Mage.php' (include_path='/var/www/vhosts/server.com/subdomains/site/httpdocs/app/code/local:/var/www/vhosts/server.com/subdomains/site/httpdocs/app/code/community:/var/www/vhosts/server.com/subdomains/site/httpdocs/app/code/core:/var/www/vhosts/server.com/subdomains/site/httpdocs/lib:.:'in /var/www/vhosts/server.com/subdomains/site/httpdocs/app/design/frontend/default/airfilter/template/Custom-Calc/complete.phtml on line 3

I double checked we didn’t need it and after getting it out (deleted) of the installation I got this new error

[root@server shell]# php -f indexer.php reindexall
Product Attributes index was rebuilt successfully
Product Prices index was rebuilt successfully
Catalog URL Rewrites index was rebuilt successfully
Product Flat Data index was rebuilt successfully
Category Flat Data index was rebuilt successfully
Category Products index was rebuilt successfully
{{{Catalog Search Index}}{{Catalog Search Index}}{{Catalog Search Index}}{{Mage_CatalogSearch}}} index was rebuilt successfully
{{{Stock Status}}{{Stock Status}}{{Stock Status}}{{Mage_CatalogInventory}}} index was rebuilt successfully
{{{Tag Aggregation Data}}{{Tag Aggregation Data}}{{Tag Aggregation Data}}{{Mage_Tag}}} index was rebuilt successfully
[root
@server shell]#

The re-index works fine until the catalog search. Once it gets to the Catalog Search Index I get these widget brackets, does anybody know what they mean?

Is this index part of moving the items from magento_catalog_product_entity to magento_catalog_product_flat_1?

I have thousands of products to upload. What else can i do to force the new items to be listed in the catalog without having to open every single one and save it again?

 
Magento Community Magento Community
Magento Community
Magento Community
 
easy2access
Jr. Member
 
Total Posts:  1
Joined:  2012-09-10
 

I have the same issue with my Magento install. I import all the products fine with the csv importer but they won’t display live until I go into the product and click save again. So strange, I need this fixed asap please.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mirasvit
Guru
 
Avatar
Total Posts:  638
Joined:  2009-08-22
 

Indeed when a large number of goods or attributes need to be saved, backend works very slow, as each time you save data the system re-indexes the goods through the entire catalog. Asynchronous Re-indexing is a solution of this problem.  When a product or category is saved it is not immediately re-indexed, but put into a queue. The queue is re-indexed in the background. This greatly speeds up the backend. This mechanism is implemented by using an extension of http://mirasvit.com/magento-extensions/magento-asynchronous-reindex.html

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top