Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Admin login suddenly stop working
 
Muthu Kumar
Member
 
Total Posts:  74
Joined:  2011-01-11
 

Hi Friends,

After a long time i came here for a problem. My site is

http://rnjpillows.com.au/demo/index.php/rnjpillows_admin/

I am using magento 1.7.0.2

I was working in this site in a week’s time. But suddenly when i am tring to login into admin using the correct username and password. It’s doesn’t reflect any invalid username/password message or it doesn’t login. I have searched for the forums and i am trying to change the code in app/code/core/Mage/Core/Model/Session/Abstract/Varien.php like this

// session cookie params
$cookieParams = array(
‘lifetime’ => $cookie->getLifetime(),
‘path’ => $cookie->getPath(),
‘domain’ => $cookie->getConfigDomain(),
‘secure’ => $cookie->isSecure(),
‘httponly’ => $cookie->getHttponly()
);

/*if (!$cookieParams[’httponly’]) {
unset($cookieParams[’httponly’]);
if (!$cookieParams[’secure’]) {
unset($cookieParams[’secure’]);
if (!$cookieParams[’domain’]) {
unset($cookieParams[’domain’]);
}
}
}

if (isset($cookieParams[’domain’])) {
$cookieParams[’domain’] = $cookie->getDomain();
}*/

But it doesn’t reflect anything for me to login

Please help me guys

Thanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
Muthu Kumar
Member
 
Total Posts:  74
Joined:  2011-01-11
 

Please help me guys. It\’s an urgent need

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Hello
First of all you have an error on the page. You are missing the Varien_Autoload class.
Second: I think the problem is happening because you have a website on Magento on http://rnjpillows.com.au/ and one on http://rnjpillows.com.au/demo.
The cookies conflict somehow. Or something else is wrong. This happened to me once.
I still don’t have a solution, but I have a way to login. You need to clear the cookies for http://rnjpillows.com.au/ and you should be able to login on /demo. but you need to do the same thing again when you try to login to http://rnjpillows.com.au/.

I know it’s not really ok, but at least you can login.
I will get back to you if I ever find a solution to my problem (which is also your problem)

Marius.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top