Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP extension “curl” must be loaded
 
mjasri
Jr. Member
 
Total Posts:  7
Joined:  2012-07-08
 

Dears,
I suffered with the below mentioed error
PHP extension “curl” must be loaded
I tried all the mentioed solutions
in PHP.INI for PHP and Apache
I removed “;” and enabled the extension
hopeless
Ihave WINdows 7
and I havemagento-1.7.0.2
and wampserver2.2e-php5.3.13-httpd2.2.22-mysql5.5.24-x64

please your help

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rich Cleverley
Sr. Member
 
Avatar
Total Posts:  285
Joined:  2009-01-20
 

Did you restart Apache?  That would apply your changes to php.ini

 
Magento Community Magento Community
Magento Community
Magento Community
 
mjasri
Jr. Member
 
Total Posts:  7
Joined:  2012-07-08
 

yes
rest the apache and the machine
is there is any change required on the other files ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rich Cleverley
Sr. Member
 
Avatar
Total Posts:  285
Joined:  2009-01-20
 

What is the location of the php.ini file you modified?  It seems Wampp has multiple php.ini files so you have to make sure you uncomment the curl.dll line in the correct file.  The easiest way to find the correct file is by running a phpinfo.php file with the following code in it

<?php
phpinfo
();

This will tell you a) where the current php.ini file is located and b) whether curl is active or not.

More info on possible locations can be found here: http://www.dibugs.com/question/curl-enabling-wamp/

 
Magento Community Magento Community
Magento Community
Magento Community
 
epvicky
Member
 
Total Posts:  59
Joined:  2011-07-28
 

Hi,

Enable the curl extension in your php.ini file of your localhost

 
Magento Community Magento Community
Magento Community
Magento Community
 
mjasri
Jr. Member
 
Total Posts:  7
Joined:  2012-07-08
 

I tried all these
hopeless

 
Magento Community Magento Community
Magento Community
Magento Community
 
ilm_mayank
Jr. Member
 
Total Posts:  6
Joined:  2012-09-14
 

first Close WAMP server if running

now go to WAMP\bin\php\your version of php\

and open your php.ini and uncomment extension=php_curl.dll

Now go to WAMP\bin\Apache\your version of apache\bin\

open php.ini file there and uncomment extension=php_curl.dll

save and restart your WAMP server

 
Magento Community Magento Community
Magento Community
Magento Community
 
zjaffery
Jr. Member
 
Total Posts:  4
Joined:  2012-09-21
 

Solution for error “PHP extension “curl” must be loaded.” In Wamp server version 2.2 for Windows 7 (64-bit Operating System) ONLY.

(Files to be Modified)
php.ini file location: C:\wamp\bin\apache\apache2.2.22\bin\
php.ini file location: C:\wamp\\bin\php\php5.3.13
phpForApache.ini file location: C:\wamp\bin\php\php5.3.13\

Find extension=php_curl.dll using find command in notepad in all above mention ini file and Remove semicolon if there is and it should look like extension=php_curl.dll

Before (;extension=php_curl.dll) after (extension=php_curl.dll)

Now download the new php_curl.dll file attached in this threat and replace it with current file. (location : C:\wamp\bin\php\php5.3.13\ext\\php_curl.dll)

You can also download new php_curl.dll file from http://tinyurl.com/axsl738

I hope it will, Thanks wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
tronitoso
Jr. Member
 
Total Posts:  1
Joined:  2010-08-23
 

Muchas gracias, Funcionó perfectamente!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
slkasun
Jr. Member
 
Total Posts:  1
Joined:  2011-12-25
 

@zjaffery Thanks.. it’s working smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
cristache
Member
 
Total Posts:  72
Joined:  2008-12-06
Bucuresti - Romania
 

works for me also, thanks smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
NucaCola
Jr. Member
 
Total Posts:  1
Joined:  2013-04-24
 

ty alot

 
Magento Community Magento Community
Magento Community
Magento Community
 
thilankaxf
Jr. Member
 
Total Posts:  7
Joined:  2012-12-10
 

Please download and replace your file with this

http://portfolio-max.blogspot.com/2013/04/curl-not-loading-error-in-apache-wamp.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
srjahir32
Jr. Member
 
Total Posts:  1
Joined:  2013-12-26
 

thanks....it works.. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top