Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal server error 500 on fresh Magento 1.7.0.2 install due to .htaccess
 
qwyrp
Member
 
Total Posts:  41
Joined:  2009-02-27
 

I did a fresh Magento 1.7.0.2 install and I get an internal server 500 error.
After running the magento-cleanup tool and disabling the htaccess-file it worked correctly.
When I enable the htacces-file I get the error again so I concluded it’s something in or with the htaccess-file.

It’s the default 1.7.0.2 htaccess file and even chmodding it to 777 didn’t do the trick.

Can somebody explain to me what to change IN the htaccess-file so it will work properly
(I test it with replacing the htaccess 1.7.0.2 with the htaccess 1.7.0 and that worked)

 
Magento Community Magento Community
Magento Community
Magento Community
 
qwyrp
Member
 
Total Posts:  41
Joined:  2009-02-27
 

Wow just after I finished this question I found the answer to my own problem.
hereby the solution:
>>>
IMPORTANT! Use the File Manager in the Control Panel to edit the .htaccess file that comes with the default set of Magento files. You need to comment out the following two lines (144 and 145) by inserting the # symbol in front of each line:

#RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
#RewriteRule .* - [L,R=405]

If the above step is not completed, the installation page will show a 500 server error.
<<

 
Magento Community Magento Community
Magento Community
Magento Community
 
FlashRope
Jr. Member
 
Total Posts:  3
Joined:  2012-12-09
 

Qwyrp,

Thank you, thank you, thank you, thank you, thank you, thank you, thank you!

Up until this point, I had struggled for over 20 hours reading post (and experimenting) trying to fix this issue. Your post saved me from eternal damnation!

Who knew two hash tags would make such a difference! You’ve made me very happy!

Best,

- T

 
Magento Community Magento Community
Magento Community
Magento Community
 
omnisity
Jr. Member
 
Total Posts:  1
Joined:  2013-02-18
 

Wonder if you can help me???

I\\\\\\\’ve installed magento-1.7.0.2 on a Fasthosts Apache 2.2 shared Server with PHP. i ran magneto-check.php which returned as follows:

Your server does not meet the following requirements in order to install Magento.

The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

You need MySQL 4.1.20 (or greater)

The following requirements were successfully met:

You have PHP 5.2.0 (or greater)
Safe Mode is off
You have the curl extension
You have the dom extension
You have the gd extension
You have the hash extension
You have the iconv extension
You have the mcrypt extension
You have the pcre extension
You have the pdo extension
You have the pdo_mysql extension
You have the simplexml extension

MySQL is hosted elsewhere so that wasn\\\\\\\’t an issue, i uploaded the files, but hit internal server error straight away. I tried commenting out the lines you suggest but still nothing. I deleted the .htaccess file which allowed be to install the system but none of the links work.

I found another post which spoke about switching of \\\\\\\"friendly URLs\\\\\\\” you can do this by:

Admin Panel > System > Configuration > Search Engines Optimization > Use Web Server Rewrites > NO

Through trial and error i tried removing section of the .htaccess file and found unless lines 116 & 117 were commented out i would receive internal server errors.

############################################
## enable rewrites

# Options +FollowSymLinks
# RewriteEngine on

As i said the system is now installed but friendly URLS do not work and none of the images on the internal pages will display. I\\\\\\\’m a newbie to PHP and the magneto system so stuggling to know what to do?

Any help will be gratefully received.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
ask4ad
Jr. Member
 
Total Posts:  1
Joined:  2013-02-20
 

Dear Sir,
i have problem in Database connection error.
please help me.

Regards

Image Attachments
Database connection error..bmp
 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Ask4ad,

You should create a user in phpMyAdmin.
Then create a password and give the full privileges on Magento database.
After these actions you should enter this data on the same page which you showed on the screenshot.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ask4ad
Jr. Member
 
Total Posts:  1
Joined:  2013-02-20
 

Dear Sir,
i create database and also put in Magento but i seen

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top