Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento Shop auf einen anderen Server umziehen -> Problem
 
user154
Member
 
Total Posts:  31
Joined:  2012-08-09
 

Hey Leute ich wollte heute meinen Magento Shop auf einen anderen Server umziehen, dabei bin ich bisher wie folgt vorgegangen.

1. Datenbank des Shops exportiert.
2. Alle Dateien per FTP auf den neuen Server kopiert.
3. Alte Datenbank importiert.
4. Datenbankzugänge geändert unter app/etc/local.xml

<config>
    <global>
        <
install>
            <
date><![CDATA[Mon29 Nov 2010 07:52:09 +0000]]></date>
        </
install>
        <
crypt>
            <
key><![CDATA[d43ec4935fe111df745140249005e4f2]]></key>
        </
crypt>
        <
disable_local_modules>false</disable_local_modules>
        <
resources>
            <
db>
                <
table_prefix><![CDATA[]]></table_prefix>
            </
db>
            <
default_setup>
                <
connection>
                    
[color=red]<host><![CDATA[localhost:/tmp/mysql5.sock]]></host>
                    <
username><![CDATA[dbo432629498]]></username>
                    <
password><![CDATA[MagentoTestseite]]></password>
                    <
dbname><![CDATA[db432629498]]></dbname>[/color]
                    
<active>1</active>
                </
connection>
            </
default_setup>
        </
resources>
        <
session_save><![CDATA[files]]></session_save>
    </global>
    <
admin>
        <
routers>
            <
adminhtml>
                <
args>
                    <
frontName><![CDATA[admin]]></frontName>
                </
args>
            </
adminhtml>
        </
routers>
    </
admin>
</
config>

5. Anpassen der Base URL in der Datenbank (web/unsecure/base_url + web/secure/base_url )

Allerdings bekomme ich nun folgenden Fehler wenn ich den Shop aufrufe

[b]There has been an error processing your request

SQLSTATE[HY000] [1045] Access denied 
for user'dbo432629498@localhost' (Using passwordYES)

Trace:[/b]
#0 /homepages/6/d68650885/htdocs/servername/shop/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /homepages/6/d68650885/htdocs/servername/shop/lib/Varien/Db/Adapter/Pdo/Mysql.php(251): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /homepages/6/d68650885/htdocs/servername/shop/lib/Zend/Db/Adapter/Abstract.php(448): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /homepages/6/d68650885/htdocs/servername/shop/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /homepages/6/d68650885/htdocs/servername/shop/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Resource.php(93): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#7 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(297): Mage_Core_Model_Resource->getConnection('core_read')
#8 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(312): Mage_Core_Model_Mysql4_Abstract->_getConnection('read')
#9 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Mysql4/Cache.php(41): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()
#10 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Cache.php(424): Mage_Core_Model_Mysql4_Cache->getAllOptions()
#11 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Cache.php(459): Mage_Core_Model_Cache->_initOptions()
#12 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/App.php(1101): Mage_Core_Model_Cache->canUse('config')
#13 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Config.php(404): Mage_Core_Model_App->useCache('config')
#14 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/Config.php(286): Mage_Core_Model_Config->_canUseCacheForInit()
#15 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/App.php(359): Mage_Core_Model_Config->loadModulesCache()
#16 /homepages/6/d68650885/htdocs/servername/shop/app/code/core/Mage/Core/Model/App.php(295): Mage_Core_Model_App->_initModules()
#17 /homepages/6/d68650885/htdocs/servername/shop/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#18 /homepages/6/d68650885/htdocs/servername/shop/index.php(80): Mage::run('', 'store')
#19 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
Siggi_Schmitz
Enthusiast
 
Avatar
Total Posts:  811
Joined:  2011-07-03
 

Gibt es den user “dbo432629498” denn und darf er auch per localhost auf die eingetragene DB zugreifen? Das Passwort stimmt auch?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top