Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Order Status will NOT Complete after ship/invoice!!! 
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

1.7 - How Do I make my orders go to ‘complete’ status?

I have a good level of experience with Magento but none of that explains why, whilst using a new site I have done with magento 1.7, my orders will simply NOT go to ‘Complete’ status (as you can imagine, that’s really annoying!).

I haven’t edited the statuses and I know that you have to invoice and ship… I’ve done all of this!

But… they are all still stuck on processing!

Can anyone offer a suggestion of anything else to check? I’m going insane with this problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Extendware
Sr. Member
 
Avatar
Total Posts:  231
Joined:  2011-08-04
 

Have you invoiced the orders?

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Orders have been invoiced AND shipped!

I have used magento before a few times so I know that this should do it!

What else could stop it completing?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Still can’t make orders complete - both invoiced and shipped.

Is there any way to check the database for any errors or problems?

- My site has been live for a month and is taking orders fine but not being able to change any of them from ‘processing’ is really annoying… If anyone can help I will be eternally grateful as long as I am trading!

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Bump!

This problem is reaaaaaallly annoying. I’ve come across and overcome all sorts of issues with magento and modified it in so many ways… so why won’t my orders on this website complete when I have shipped and invoiced and not touched the default order statuses?!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

BUMP!… Sigh…

OK, I don’t think I need to re-summarise (BUT: orders won’t complete despite being shipped and invoiced in 1.7)… I can’t believe no one has any suggestions… I’ve solved and help others solve far more complicated things on here!

And… I bet someone else has had this problem…

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Bump!

Someone… surely?!

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Bump :(

Is there a possibility that there’s a problem in my order states? Ach, I’ve looked into everything I can think of…

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

SOLVED!

This turned out to be a bug in my payment module (using secure trading’s payment pages) that has now been rectified by the developer.

However - I still have some old orders that STILL will not complete… but my new ones now will.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jimmy_mac
Newbie
 
Total Posts:  0
Joined:  2013-01-11
 

I’ve got the exact same issue. Payment processing hiccuped when the gateway triggered a potential fraud situation. Order was still Invoiced, but some magic is missing. Did you ever determine what didn’t get set in Magento?

 
Magento Community Magento Community
Magento Community
Magento Community
 
joejoe
Sr. Member
 
Total Posts:  102
Joined:  2011-01-21
 

Not sure what they did unfortunately… it was a major update to the module which is now very old, I don’t think I could find out now I’m sorry to say.

Good luck though!

 
Magento Community Magento Community
Magento Community
Magento Community
 
thenergle
Jr. Member
 
Total Posts:  20
Joined:  2010-07-08
 

Same problem here but using the Magento Paypal Webmaster Pro. Orders are getting shipped payment is getting processed and captured correctly, but then we get two invoices for the same order and the status won’t change from Processing to complete. Any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunezapa
Jr. Member
 
Total Posts:  4
Joined:  2013-06-28
 

Same problem - 3 orders are Processing, even payment is done,by clicking Invoice and take money.
Payment is done, no invoice/shipment records is created.
There are no invoice/ship buttons anymore!

Problem was created while the IP of the server was momentary blocked at the payment gateway.
How to change from Processing to Completed - or get back the Invoice/Ship buttons, that would make it possible to get Completed status.

The customers has their order shipped, but we cannot make invoice, and the orders are stucked in Processing state :-(

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top