Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade von 1.4.x auf 1.7.x
 
vkemeter
Jr. Member
 
Total Posts:  16
Joined:  2010-08-08
 

Hi,

ich versuche gerade eine altlast, die mir übertragen wurde, auf 1.7.x zu aktualisieren. bisher mit mässigem erfolg. folgende schritte bin ich dabei durchgegangen:

http://turnkeye.com/blog/magento-upgrade-guide/
http://www.magentocommerce.com/wiki/groups/227/resetting_file_permissions

auf 1.4.2.0 lässt sich noch alles problemlos aktualisieren und es funktioniert. die aktualisierung danach bringt immer einen anderen fehler. aktuell habe ich folgendes:

a:5:{i:0;s:94:"Invalid method Mage_Core_Block_Messages::addStorageType(Array
(
    [0] => catalog/session
)
)"
;i:1;s:1335:"#0 [internal function]: Varien_Object->__call('addStorageType', Array)
#1 /htdocs/app/code/core/Mage/Cms/Helper/Page.php(131): Mage_Core_Block_Messages->addStorageType('catalog/session')
#2 /htdocs/app/code/core/Mage/Cms/Helper/Page.php(52): Mage_Cms_Helper_Page->_renderPage(Object(Mage_Cms_IndexController), 'home')
#3 /htdocs/app/code/core/Mage/Cms/controllers/IndexController.php(45): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'home')
#4 /htdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(419): Mage_Cms_IndexController->indexAction()
#5 /htdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
#6 /htdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#7 /htdocs/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#8 /htdocs/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#9 /htdocs/index.php(87): Mage::run('', 'store')
#10 {main}"
;s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:2:"de";}

habt ihr irgendwelche sinnvollen tips, wie allgemein mit so einer altlast umzugehen ist? gibts ein wundermittel, um den shop vernünftig zu aktualisieren?

danke für eure hilfe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
IT_Zehaczek
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-12-18
 

Ich musste auch einen Shop sogar von 1.3 auf 1.7 migrieren und das von dir Geschilderte ist genau der Grund, warum ich es gar nicht erst per Update-Marathon versucht habe.

Ich bin einen anderen Weg gegangen und habe dazu mal einen Artikel geschrieben, vielleicht ist der dort beschriebene Lösungsweg ja auch eine Alternative für dich.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nilsdomian1
Jr. Member
 
Total Posts:  4
Joined:  2012-01-02
 

ich hab das einfach auskommentiert und das Update realisiert. das an 2 weiteren Stellen wo es mit addStorageType Probleme gibt. Anschliessend läuft alles wie gewünscht, jedenfalls bei mir.

 
Magento Community Magento Community
Magento Community
Magento Community
 
miss_magenta
Member
 
Avatar
Total Posts:  49
Joined:  2010-04-22
 

Ich habe bisher jedes Upgrade gut hinbekommen, mit dieser Methode:

http://neoshops.de/2013/08/03/how-to-upgrade-magento-using-old-database/

Das kommt zwar einer Neuinstallation nahe, aber man weiß einfach, dass jedes Modul für die neue Version geeignet ist und welches ggf. Probleme bereitet. Diesen Weg bin ich mit u.a. mit 1.3 auf 1.5 und 1.4.1 auf 1.8 gegangen - und alle laufen noch wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top