Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Module TNT ne s’affiche pas en front end
 
aypepito
Jr. Member
 
Total Posts:  15
Joined:  2008-07-14
 

Bonjour,

j’ai installé le module TNT sur mon site en passant par magento connect, tout fonctionne bien en back end, mais, lorsque je vais dans client, l’option TNT ne s’affiche pas en front end.
J’ai investigué un peu, et j’ai bien constaté qu’au moment de sélectionner le moyen de livraison, il passe dans le fichier :

app\design\frontend\default\default\template\tnt\onepage\shipping_method\available.phtml

et notamment dans le code :

<?php if (!($_shippingRateGroups $this->getShippingRates())): ?>
    
<p><?php echo $this->__('Sorry, no quotes are available for this order at this time.'?></p>
    
<?php else: ?>        
    
<dl class="sp-methods">

    
    
<?php     $_sole count($_shippingRateGroups) == 1
            
               
$quote Mage::getSingleton('checkout/session')->getQuote();               

            foreach (
$_shippingRateGroups as $code => $_rates): ?>
        
<dt><?php echo $this->getCarrierName($code?></dt>
........

et à ce moment là, la boucle foreach ne liste jamais le module TNT alors qu’il est coché comme activé dans le backend…

Avez vous une idée ? Il manque quelque chose ?
merci.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top