Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Quick Search not working on 1.7 - only shows results for some newer products
 
TheBigLaskowski
Jr. Member
 
Total Posts:  6
Joined:  2010-05-11
 

Recently I noticed the search function on a website I’m developing is no longer working correctly. It at one point was working just fine. When preforming a search for some of the most basic items in the store no results will show up. It’s a lingerie store so when searching for one word items like teddy, corset, leather, etc nothing shows up. However when searching for multiplier words like “leather corset” some items show but not all of the leather corsets on the website.

I’ve read every forum message possible relating to the search function not working and I’ve tried everything possible for every version of Magento that’s been listed. Some with very similar problems had solutions posted that would not work for me.

Rebuilt the table in my database, truncated the table and re-indexed, cleared the cache and var folders, made edits to FullText.php, catalogsearch.xml, re-indexed a dozen times, back and forth tried everything and still nada..... Very frustrated.

Any insight on this issue would be very much appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mirasvit
Guru
 
Avatar
Total Posts:  639
Joined:  2009-08-22
 

Hi,

In fact, default Magento search is not perfect. Very often a user doesn’t find what he was looking for and leaves the store. Good decision is to integrate the Sphinx search engine. It greatly improves the quality and relevance of search results. Look at Sphinx Search Ultimate

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top