Magento Forum

Nach Serverumzug Probleme im Admin- / Loginbereich
 
afbmedia
Jr. Member
 
Total Posts:  2
Joined:  2012-07-02
 

Hallo,

ich hatte zuvor einen Shop unter Magento 1.7 aufgebaut. Nun gab es einen Serverwechsel und ich komme nicht mehr ins Backend rein.
Zum einen werden beim Aufruf des Admin-Menüs (Loginbox) keine Javascript und CSS-Datein geladen.
Wenn man sich den Quelltext anschaut, merkt man, dass die betreffenden URLs unvollständig sind.
Beispielsweise für die CSS: /adminhtml/default/default/reset.css ... es fehlt also die Domain sowie der ordner “skin” davor.

Außerdem erscheint die Fehlermeldung “Fatal error: Call to a member function getBlockName() on a non-object in /pages/ce/94/d0008682/home/htdocs/shop/app/code/core/Mage/Captcha/Block/Captcha.php on line 43”

Der Loginbutton erscheint durch diese Fehlermeldung schon gar nicht mehr, so dass ich mich wie gesagt auch gar nicht erst einloggen kann.

Kann mir jemand sagen, wieso diese Fehler nun auftreten bzw. wie ich diese beheben kann?

Schonmal vielen Dank.

Grüße

 
Magento Community Magento Community
Magento Community
Magento Community
 
sringel
Member
 
Avatar
Total Posts:  55
Joined:  2012-02-20
 

Hallo,

bitte checke mal in der Datenbank “core_config_data”, ob die URL richtig eingetragen wurde.

Hat sich sonst etwas am Shop verändert?

Viele Grüße,

Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
afbmedia
Jr. Member
 
Total Posts:  2
Joined:  2012-07-02
 

Hallo,

danke für die schnelle Antwort.

Die zwei Felder in der Datenbank habe ich bereits überprüft, die URL steht richtig geschrieben drin.
Ansonsten wurde nichts am Shop verändert, ist der gleiche Zustand wie zuvor auf dem alten Server.

Grüße

 
Magento Community Magento Community
Magento Community
Magento Community
 
sringel
Member
 
Avatar
Total Posts:  55
Joined:  2012-02-20
 

Es muss also mehr Unterschiede geben.

Gibt es absolute Pfade bei der alten Installation?

Wurde der Cache gelöscht?

Ist eine htaccess vorhanden?

Ist díe vhost vom Webserver korrekt?

Sind die Rechte alle korrekt, vor allem von der htaccess?

VIel Erfolg bei der Suche smile

Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top