Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

internal server error and no installation
 
aadamb
Jr. Member
 
Total Posts:  5
Joined:  2012-08-29
 

hi,

I’ve been trying to install magento on a hosting server, and so far get only error 500 quoted below, or nothing but blank pages.
on my linux machine it all works fine via xampp.
I’m using magento version 1.7.0.2 full (downloader did the same), and it’s a clean install, not an upgrade.
all file permissions are set to 755 for the time being just to be sure.

the error is:

Internal Server Error

The server encountered an internal error 
or misconfiguration and was unable to complete your request.

Please contact the server administrator[no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache Server at domain.com Port 80

server info:
-apache 2
-PHP Version 5.2.17-pl1-gentoo
-mysql Client API version 5.1.56
-pdo_mysql PDO Driver for MySQL, client library version 5.1.56
-msqli Client API library version 5.1.56, Client API header version 5.1.56

not sure about these two in the “how to ask questions”:
type of your hosting account (shared hosting or virtual/dedicated server), and how PHP is run - as Apache module or CGI/FastCGI

link to phpinfo.php

what have I tried: download .tar.gz files twice and .zip once, tried downloader (one file? downloader.php) twice all the same.
tried migrating my working local installation per the instructions, nada.
tried file permissions 777 and 755 for the relevent directories and 644 for the rest (also 777 for all dirs/files and 755 for all).

point of raised eyebrow: there was a difference of 20/30 K files between tar.gz and .zip archives.

everything I did only ever lead to a blank page if I tweaked .htaccess (in which case index.php at least shows a sign of life before stopping)
or this unmovable 500 error.

any suggestions would be much appreciated.

adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

please check your error log,
usually if you do default server install, with default magento install - everything should work.

apache and php error logs will tell you all you need.

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

As already mentioned, the Apache logs should give you additional information, but you can try to rename the .htaccess file temporarily to see if the 500 error goes away. If it does, there are some directives not supported by your hosting server.

Have you tried to run the Magento compatibility check?
http://www.magentocommerce.com/knowledge-base/entry/how-do-i-know-if-my-server-is-compatible-with-magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
aadamb
Jr. Member
 
Total Posts:  5
Joined:  2012-08-29
 

thanks for your replies,

yes, I ran the check and the server seems compatible:

CongratulationsYour server meets the requirements for Magento.

    
You have PHP 5.2.0 (or greater)
    
Safe Mode is off
    You have MySQL 4.1.20 
(or greater)
    
You have the curl extension
    You have the dom extension
    You have the gd extension
    You have the hash extension
    You have the iconv extension
    You have the mcrypt extension
    You have the pcre extension
    You have the pdo extension
    You have the pdo_mysql extension
    You have the simplexml extension

but…

.htaccess - indeed, I asked my hosting provider and he said this:

\"your .htaccess contains several unallowed directives. I commented them so that it should work now. Here you can see the diff:\”

# diff -uN .htaccess.bak .htaccess
--- .htaccess.bak       2012-09-04 12:28:37.000000000 +0200
+++ .htaccess   2012-09-06 10:03:56.000000000 +0200
@@ -38,13 +38,13 @@
 
############################################
 ## disable magic quotes for php request vars

-    php_flag magic_quotes_gpc off
+#    php_flag magic_quotes_gpc off

 ############################################
 ## disable automatic session start
 ## before autoload was initialized

-    php_flag session.auto_start off
+#    php_flag session.auto_start off

 ############################################
 ## enable resulting html compression
@@ -54,12 +54,12 @@
 
###########################################
 # disable user agent verification to not break multiple image upload

-    php_flag suhosin.session.cryptua off
+#    php_flag suhosin.session.cryptua off

 ###########################################
 # turn off compatibility with PHP4 when dealing with objects

-    php_flag zend.ze1_compatibility_mode Off
+#    php_flag zend.ze1_compatibility_mode Off

 
</IfModule>

@@ -
104,+104,@@
 
############################################
 ## make HTTPS env vars available for CGI mode

-    SSLOptions StdEnvVars
+#    SSLOptions StdEnvVars

 
</IfModule>

@@ -
113,+113,@@
 
############################################
 ## enable rewrites

-    Options +FollowSymLinks
+#    Options +FollowSymLinks
     
RewriteEngine on

but now I get only blank pages.
any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Regarding white pages, check the PHP error log or turn on error reporting. A white page usually indicates a PHP error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aadamb
Jr. Member
 
Total Posts:  5
Joined:  2012-08-29
 

the errors are include errors, and (include_path=’.’):

Warning: include_once(Mage/Core/functions.php[function.include-once]failed to open streamNo such file or directory in /var/www/web5/html/magento/app/Mage.php on line 49

Warning
: include_once() [function.include]Failed opening 'Mage/Core/functions.php' for inclusion (include_path='.'in /var/www/web5/html/magento/app/Mage.php on line 49

Warning
: include_once(Varien/Autoload.php[function.include-once]failed to open streamNo such file or directory in /var/www/web5/html/magento/app/Mage.php on line 50

Warning
: include_once() [function.include]Failed opening 'Varien/Autoload.php' for inclusion (include_path='.'in /var/www/web5/html/magento/app/Mage.php on line 50

Fatal error
: Class 'Varien_Autoload' not found in /var/www/web5/html/magento/app/Mage.php on line 53

I have not managed to point magento in the right direction,
how can it be done?

 
Magento Community Magento Community
Magento Community
Magento Community
 
aadamb
Jr. Member
 
Total Posts:  5
Joined:  2012-08-29
 

Resolved

For reference, the issue lay in an old include_path in the host’s apache configuration.
I managed to re-create the problem locally on xammp using

php_admin_value include_path "."
in httpd.conf

The admin value cannot be overriden by magento’s set_include_path as opposed to
php_value include_path, which can be.
After removal it now works.

Cheers,
Adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
mac1959
Jr. Member
 
Total Posts:  2
Joined:  2012-10-04
 
aadamb - 14 September 2012 11:44 PM

Resolved

For reference, the issue lay in an old include_path in the host’s apache configuration.
I managed to re-create the problem locally on xammp using

php_admin_value include_path "."
in httpd.conf

The admin value cannot be overriden by magento’s set_include_path as opposed to
php_value include_path, which can be.
After removal it now works.

Cheers,
Adam

Which one did you remove? and where did you remove it from?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mac1959
Jr. Member
 
Total Posts:  2
Joined:  2012-10-04
 
mac1959 - 03 November 2012 08:39 AM

aadamb - 14 September 2012 11:44 PM
Resolved

For reference, the issue lay in an old include_path in the host’s apache configuration.
I managed to re-create the problem locally on xammp using
php_admin_value include_path "."
in httpd.conf

The admin value cannot be overriden by magento’s set_include_path as opposed to
php_value include_path, which can be.
After removal it now works.

Cheers,
Adam

Which one did you remove? and where did you remove it from?

lol never mind I got it.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top