Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

memory_limit wird ignoriert
 
alexri
Jr. Member
 
Total Posts:  5
Joined:  2012-02-17
 

Hallo,

so langsam weiß ich nicht mehr weiter ... zuerst die Fehlermeldung:

[29-Aug-2012 13:23:08] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in /var/www/vhosts/xxxxxxx/httpdocs/app/code/core/Mage/Eav/Model/Entity/Attribute/Source/Table.php on line 62

Mir ist klar, dass die Fehlermeldung besagt, dass der Speicher mit 128MB ausgelastet ist.

Aber ich habe bereits das memory_limit in der php.ini, .htaccess und im Script selbst auf 1024MB hochgesetzt. Phpinfo gibt mir das auch so wieder.

Ich nutze Debian Squeeze, PHP 5.3.3-7+squeeze14. Magento Version ist 1.6.2.

Ist das ein BUG o.ä.? Weiß jemand weiter?

VG

 
Magento Community Magento Community
Magento Community
Magento Community
 
MarkusSchneider
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2011-12-13
 

da musst du das irgendwo übersehen haben, vielleicht in deiner index.php von Magento?

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexri
Jr. Member
 
Total Posts:  5
Joined:  2012-02-17
 

Die index.php und mage.php hab ich ebenfalls schon mit ini_set bearbeitet. Gibt es noch eine Datei die fehlt?

VG

 
Magento Community Magento Community
Magento Community
Magento Community
 
sringel
Member
 
Avatar
Total Posts:  55
Joined:  2012-02-20
 

Poste doch mal deine php.ini.

Es ist kein Bug, sondern ein Fehler in der Konfiguration.
Checke mal, ob die php.ini korrekt ist

find / -name php.ini

Checke, ob der php.ini Wert durch einen weiteren Parameter, der gesetzt wird, überschrieben wird.

Viele Grüße,

Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexri
Jr. Member
 
Total Posts:  5
Joined:  2012-02-17
 

Hallo,

also ich konnte das Problem in zwischen Zeit lösen.

Bei mir lag es daran, dass die php.ini in /etc/php5/cli/php.ini und /etc/php5/cgi/php.ini noch angepasst wurden musste. Anscheint ändert Plesk diese Dateien nicht.

Nur nun habe ich ein neues Problem

Premature end of script headers: index.php

und

mod_fcgid: read data timeout in 45 seconds

wird mir im error log angezeigt.

Hat jemand schonmal Erfahrungen damit gemacht?

VG

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexri
Jr. Member
 
Total Posts:  5
Joined:  2012-02-17
 

Problem ebenfalls gelöst. Magento kam anscheind nicht mit FastCGI klar. Unter dem normalen CGI läuft es!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top