Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PDO and PDO MySQL
 
Virtaweb
Jr. Member
 
Total Posts:  3
Joined:  2012-08-27
 

magento-check.php giving the following error

Your server does not meet the following requirements in order to install Magento.
The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

You are missing the pdo extension
You are missing the pdo_mysql extension

yet the config command of phpinfo () shows:

Command \\\’./configure\\\’ \\\’--disable-fileinfo\\\’ \\\’--disable-phar\\\’ \\\’--enable-bcmath\\\’ \\\’--enable-calendar\\\’ \\\’--enable-ftp\\\’ \\\’--enable-gd-native-ttf\\\’ \\\’--enable-libxml\\\’ \\\’--enable-magic-quotes\\\’ \\\’--enable-mbstring\\\’ \\\’--enable-pdo=shared\\\’ \\\’--enable-soap\\\’ \\\’--enable-sockets\\\’ \\\’--enable-ucd-snmp-hack\\\’ \\\’--enable-wddx\\\’ \\\’--enable-zend-multibyte\\\’ \\\’--enable-zip\\\’ \\\’--prefix=/usr\\\’ \\\’--with-bz2\\\’ \\\’--with-curl=/opt/curlssl/\\\’ \\\’--with-curlwrappers\\\’ \\\’--with-freetype-dir=/usr\\\’ \\\’--with-gd\\\’ \\\’--with-gettext\\\’ \\\’--with-imap=/opt/php_with_imap_client/\\\’ \\\’--with-imap-ssl=/usr\\\’ \\\’--with-jpeg-dir=/usr\\\’ \\\’--with-kerberos\\\’ \\\’--with-libdir=lib64\\\’ \\\’--with-libexpat-dir=/usr\\\’ \\\’--with-libxml-dir=/opt/xml2\\\’ \\\’--with-libxml-dir=/opt/xml2/\\\’ \\\’--with-mcrypt=/opt/libmcrypt/\\\’ \\\’--with-mm=/opt/mm/\\\’ \\\’--with-mysql=/usr\\\’ \\\’--with-mysql-sock=/var/lib/mysql/mysql.sock\\\’ \\\’--with-mysqli=/usr/bin/mysql_config\\\’ \\\’--with-openssl=/usr\\\’ \\\’--with-openssl-dir=/usr\\\’ \\\’--with-pcre-regex=/opt/pcre\\\’ \\\’--with-pdo-mysql=shared\\\’ \\\’--with-pdo-sqlite=shared\\\’ \\\’--with-pic\\\’ \\\’--with-png-dir=/usr\\\’ \\\’--with-pspell\\\’ \\\’--with-snmp\\\’ \\\’--with-sqlite=shared\\\’ \\\’--with-tidy=/opt/tidy/\\\’ \\\’--with-xmlrpc\\\’ \\\’--with-xpm-dir=/usr\\\’ \\\’--with-xsl=/opt/xslt/\\\’ \\\’--with-zlib\\\’ \\\’--with-zlib-dir=/usr\\\’

What am I not getting?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Virtaweb
Jr. Member
 
Total Posts:  3
Joined:  2012-08-27
 

Since I still don’t have a response, I will add information to try to get one:

link to phpinfo:  http://virtasite.com/magento/info.php

I’ve turned on debug information by adding/changing the following in index.php

Mage::setIsDeveloperMode(true);
ini_set(’display_errors’, 1);

I really don’t know what to do / try next.  This is not turning out as I expected.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ackley
Jr. Member
 
Total Posts:  28
Joined:  2012-08-24
 

According to me magento installation is step by step process. The first you are download the magento Package form the internet and then go the C-panel through the FTP file format, third step is to Create the mysql database and then install the Magento folder in your system, Skip the URL in the option and then click the install button to complete the installation.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Virtaweb
Jr. Member
 
Total Posts:  3
Joined:  2012-08-27
 

Problem has been solved, there was a misconfiguration in my php.ini file that was causing problems.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top