Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 3 of 3
How to apply v0.7.15480 Upgrade on 1&1
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@Catia: actually this line exists in stock .htaccess:

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php

/index.php/ will always exist in URLs for admin and install, and can be removed in frontend URLs by editing configuration value in Admin > System > Config > Web > Use Web Server Rewrites = Yes.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DDMAN
Sr. Member
 
Total Posts:  179
Joined:  2008-01-08
 

I’m doing a fresh install on 1and1 and it is working fine until I get to the point where it ask for the database information. When I input the database information it gives me a access denied error.

SQLSTATE[28000] [1045] Access denied for user 'dbxxxxxxxxx'@'xx.xxx.xx.xxx' (using passwordYES)
Database connection error

I previously installed version 0.7.14800 fine without errors for database.

My last installation I installed on a domain http://www.mydomain.com and this pointed to a folder in my 1and1 shared account that was not the root folder of my account. It worked fine.

Now I am installing the newest version 0.7.15480 on another domain that points to a different folder in my 1and1 account that is also not the root folder of my 1and1 account. This domain is store.myotherdomain.com so it is using a subdomain that is pointing to the folder where I’m installing 7.15480

the domain http://www.myotherdomain.com is actually on a different host and I simply have the subdomain store.myotherdomain.com pointing to my 1and1 account.

I’m thinking my database access denied is related to this issue and not Magento but I thought I’d post it to see if others are experiencing this. I’m contacting 1and1 support as well

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

@Moshe

What I was trying to say in my previous post is that I need <u>both</u> an AddType and an AddHandler command for PHP5 to work with my 1&1;account, as follows:

AddType x-mapp-php5 .php
AddHandler x
-mapp-php5 .php
If either one of these commands is missing, I get the “Whoops, it looks like you have an invalid PHP version” error.  I am not sure why this is the case, since other 1&1;users seem to get by with just the “AddType” command that you included in the stock .htaccess… But I thought I would mention this particularity anyways.
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 3 of 3