Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
How to apply v0.7.15480 Upgrade on 1&1
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I tried to do an upgrade as shown in your video.  When the upgrade runs, it spits out the following in the PEAR dialog (upgrade only lasts for a few seconds):

Upgrading all available packagesplease wait...

Will upgrade channel://connect.magentocommerce.com/core/mage_pear_helpers
Will upgrade channel://pear.php.net/pear
Did not download optional dependenciespear/XML_RPC, use --alldeps to download automatically
pear
/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0)
downloading Mage_Pear_Helpers-0.7.15480.tgz ...
Starting to download Mage_Pear_Helpers-0.7.15480.tgz (9,262 bytes)
.....
done9,262 bytes
downloading PEAR
-1.7.0RC2.tgz ...
Starting to download PEAR-1.7.0RC2.tgz (298,557 bytes)
...
done298,557 bytes
upgrade
-all okchannel://pear.php.net/PEAR-1.7.0RC2
upgrade-all okchannel://connect.magentocommerce.com/core/Mage_Pear_Helpers-0.7.15480
PEAROptional feature webinstaller available (PEAR's web-based installer)
PEAR: Optional feature gtkinstaller available (PEAR'
s PHP-GTK-based installer)
PEAROptional feature gtk2installer available (PEAR's PHP-GTK2-based installer)
PEAR: To install optional features use "pear install pear/PEAR#featurename"

When I log out and log back in it still is showing 0.7.14800.

Keep in mind, I modified that list of files in the previous install in order to get it to work on 1&1.  I just finished setting up all our test products (over 100), so I’d really prefer not to start over from scratch.

Any ideas?  Thanks!

Brady

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

First of all it is always a good idea to make a backup of your database, and files if you made any customizations.

In your admin go to System / Extensions / Locally installed.

See which ones you have installed the last time, these ones are going to be upgraded.

If you do not see Interface_Adminhtml_Default installed, that means you have downloaded complete package and did not use PEAR for installation.
In that case you will need to go to System / Extensions / Remotely Available, choose Interface_Adminhtml_Default, go to Actions tab, click Install.
Repeat this procedure for Interface_Frontend_Default and Interface_Install_Default.

Log out from admin, log in, and clean the cache in System / Cache management.

Again, make sure to have backup of your data before you start.
In worth case you can run clean installation of new versions on your database and Magento will upgrade it automatically.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Also, make backup of your .htaccess before PEAR install or upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

Thanks Moshe.

When I try the procedure you describe, the PEAR dialog appears to only be downloading the packages, but not installing them.

Transaction of Interface_Adminhtml_Default:

Downloading and installing connect.magentocommerce.com/core/Interface_Adminhtml_Defaultplease wait...

downloading Interface_Adminhtml_Default-0.7.15480.tgz ...
Starting to download Interface_Adminhtml_Default-0.7.15480.tgz (532,922 bytes)
........................................................................
done532,922 bytes
downloading Mage_All
-0.7.15480.tgz ...
Starting to download Mage_All-0.7.15480.tgz (1,928,493 bytes)
...
done1,928,493 bytes
downloading Lib_Varien
-0.7.15480.tgz ...
Starting to download Lib_Varien-0.7.15480.tgz (81,160 bytes)
...
done81,160 bytes
downloading Lib_ZF
-0.7.15480.tgz ...
Starting to download Lib_ZF-0.7.15480.tgz (2,083,995 bytes)
...
done2,083,995 bytes

I logout, log back in, clean the caches and still reporting 0.7.14800.  How do I go about doing a clean install, but keep my products available?  I have done a backup through Magento as well as MySQL and have a copy of the “media” folder and all files I customized.

Thanks!

Brady

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

It might take some time to download the files and install them, don’t refresh or navigate out of the page before it stopped loading.

If this still doesn’t work, make a clean installation of complete package, and during installation point it to the database that contains your old data.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I’m going to try a clean install.

Should I use the “Package Management through the Web” “Preferred stability: BETA” option?

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I tried a clean install with the “Beta” PEAR install option.  How do I know when it’s done downloading?

Here’s the last messages I see in the PEAR dialog:

install okchannel://pear.php.net/Archive_Tar-1.3.2
install okchannel://pear.php.net/Structures_Graph-1.0.2
install okchannel://pear.php.net/Console_Getopt-1.2.3
install okchannel://pear.php.net/PEAR-1.6.2
install okchannel://connect.magentocommerce.com/core/Mage_Pear_Helpers-0.7.15480

It’s been sitting for about 5 minutes.  Is it suppose to automatically go to the next page, or am I suppose to refresh the page or something?

This is the farthest the installation has gone for me on 1&1 without modifying any files (except the adding the 1&1 PHP5 code to the .htaccess).

Thanks!

Brady

 
Magento Community Magento Community
Magento Community
Magento Community
 
Electric-dsctc
Member
 
Avatar
Total Posts:  35
Joined:  2008-01-21
 

Hi there… I also upgraded my version from 0.7.14800 to 0.7.15480 but after finishing installing my admin still shows 0.7.14800.
I have all cache disabled.  I have Interface_Adminhtml_Default installed. I have finished the download/install ; and if I try it again it says “Nothing to upgrade-all”
Any simple way to actually know if I have the latest version....? I don’t care if the version number at the footer does not update..but I want to keep up-to-date with the releases.
Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

Hi Moshe,

Could this be because 1&1 runs PHP 4 natively?  in order to run PHP5 you have to add a line to the .htaccess file, but does the PEAR installer even see/read the .htaccess file, or is it seeing the server as still running PHP4?

I don’t know much about server setups, so I could be throwing ideas in the dark here.

Thanks!

Brady

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I REALLY think this whole “.htaccess to use PHP5” thing is the problem.

When I try to run the manual installation through SSH using “./pear install mage-core/Mage_Pear_Helpers mage-core/Lib_ZF mage-core/Lib_Varien”, I receive the following:

Ignoring installed package mage-core/Mage_Pear_Helpers
mage
-core/Lib_ZF requires PHP (version >= 5.2.0version <= 6.0.0excluded versions6.0.0), installed version is 4.4.7
mage
-core/Lib_Varien requires PHP (version >= 5.2.0version <= 6.0.0excluded versions6.0.0), installed version is 4.4.7
mage
-core/Lib_Varien requires package "mage-core/Lib_ZF" (version >= 0.7.15480)
mage-core/Lib_Varien requires PHP extension "pdo_mysql"
mage-core/Lib_Varien requires PHP extension "SimpleXML"
mage-core/Lib_Varien requires PHP extension "dom"
mage-core/Lib_Varien requires PHP extension "SPL"
No valid packages found
install failed

As noted in the error above, it’s seeing PHP version 4.4.7, not PHP 5.20 or above.

EDIT: I have an email in to 1&1 Tech Support about the ability to support PHP 5 with PEAR.  I’ll post in this thread when I hear back from them.

 
Magento Community Magento Community
Magento Community
Magento Community
 
NueBe
Member
 
Total Posts:  65
Joined:  2007-09-30
Tres Cantos - Madrid - Spain
 

where is “admin go to System / Extensions / Locally installed.” ???

im waitting about 5 minutes and see it:

downloading Interface_Adminhtml_Default-0.7.15480.tgz ...
Starting to download Interface_Adminhtml_Default-0.7.15480.tgz (532,922 bytes)
...done: 532,922 bytes
downloading Interface_Install_Default-0.7.15480.tgz ...
Starting to download Interface_Install_Default-0.7.15480.tgz (111,740 bytes)
...done: 111,740 bytes

I have to wait more? or what i have to do ?

Im instaling a seconw shop in my server

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

Hi Brady

I am in the same situation when trying to install the latest version of Magento.  The “BETA” automatic download never goes past this line:

install okchannel://connect.magentocommerce.com/core/Mage_Pear_Helpers-0.7.15480

I’ll be following this thread to find the solution!

Catia

 
Magento Community Magento Community
Magento Community
Magento Community
 
NueBe
Member
 
Total Posts:  65
Joined:  2007-09-30
Tres Cantos - Madrid - Spain
 

ok, i have install, thanks Moshe

 
Magento Community Magento Community
Magento Community
Magento Community
 
MS24
Jr. Member
 
Total Posts:  4
Joined:  2007-10-13
Germany - Wiesbaden
 

Can you tell us how you got it working? I’m having the same issues…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Benedikt
Jr. Member
 
Total Posts:  14
Joined:  2008-01-30
 

Hello Guys, I have got the same problem an can’t get it to work. It already startet during the installation process on the 1&1;Server. PEAR starts to download but does not come to the end. I used the “continue manually” function after downloading as far as I got and recived a - some kind ofg - working installation of Magento.

After reading a lot in the board I chmoded ALL files to 777 but that didn’t help as well.

While trying to install “System / Extensions / Remotely Available, choose Interface_Adminhtml_Default” the same thing happens. Magento downloads some files but does not finish the installation.

Is there any kind of solution to manually install the updates without using PEAR and without having admin access to the server (only FTP access)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Electric-dsctc
Member
 
Avatar
Total Posts:  35
Joined:  2008-01-21
 

Hi there....
I did the install but the version is still 0.7.14800 !! the pear install says that I have nothing else to install/upgrade ; but as I checked the blog today and saw that the path hints are on this new version, I realised I’m still with the old one, because I don’t have that.
How can I do another upgrade or install...?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3