Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[Resolved] “You need MySQL 4.1.20 (or greater)” issue
 
dkjoomla
Jr. Member
 
Total Posts:  6
Joined:  2011-12-27
 

Hi,

<?php phpinfo();?> says that the current version of MySQL on my Server is 5.0.92 (If I’m not wrong)

mysql
MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.0.92
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient

But, when I use file magento-check.php to check my server ability for magento it says as bellowing. Can anyone please advise?

You need MySQL 4.1.20 (or greater)
The following requirements were successfully met:
You have PHP 5.2.0 (or greater)
Safe Mode is off
You have the curl extension
You have the dom extension
You have the gd extension
You have the hash extension
You have the iconv extension
You have the mcrypt extension
You have the pcre extension
You have the pdo extension
You have the pdo_mysql extension
You have the simplexml extension

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkjoomla
Jr. Member
 
Total Posts:  6
Joined:  2011-12-27
 

To fix this issue Go to PHP Config and enable shell_exec

For me the PHP Config is located at: My Server/KloxoAdmin/Web-Mail-Database/PhpConfig/Advanced PHP Config - Disable Functions BLOCK.

Removed shell_exec from Disable functions blocks then make a refresh of magento-check.php page and both Warning message and “You need MySQL 4.1.20 (or greater)” issue are gone.

 
Magento Community Magento Community
Magento Community
Magento Community
 
drewk538
Jr. Member
 
Total Posts:  1
Joined:  2012-11-14
 

I had to put mysql into my path.

In windows
Control Panel
System
Advanced System Settings
Environment Variables
Path
Click Edit Button
I put this at the end ;C:\wamp\bin\mysql\mysql5.5.20\bin
(or whatever your path to MYSQL is)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top