Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

URL Issue
 
xplain
Jr. Member
 
Total Posts:  5
Joined:  2012-03-17
 

I have a brand new Magento Install, version 1.7.0.2. I have the base URL set to https://mysite.com/ for both secure and unsecure. When go to https://mysite.com, http://mysite.com, or https://mysite.com/index.php, the page works fine. All of the links in the page however, go to URLs like https://mysite.com/customers/ or an internal URL like that, which my server cant find, because it needs to be after index.php. (If i manually retype the url to http://mysite.com/index.php/customers/, it works.) However, if I change the base URL to include index.php (https://mysite.com/index.php) or create a rewrite to add index.php, stylesheets wont load and some pages try to look for https://mysite.com/index.php/index.php/url. Is this a webserver configuration issue? If anyone has any ideas on this, I thank you in advance for your help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

What does your .htaccess file contain? Is URL rewrites enabled on the server? (e.g. Apache mod_rewrite).

 
Magento Community Magento Community
Magento Community
Magento Community
 
xplain
Jr. Member
 
Total Posts:  5
Joined:  2012-03-17
 

The only lines active in the .htaccess file right now are:

RewriteCond %{SERVER_PORT} 80
RewriteRule 
^(.*)$ https://shop.mactech.com/$1 [R,L]
This is to redirect everyone to use SSL, the problem persists if these lines are removed.

EDIT: Solved using info from this post

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Yes, that is the problem. You were missing the url rewrite rules for Magento. Replaced the .htaccess with the default one from the installation package would have solved it as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xplain
Jr. Member
 
Total Posts:  5
Joined:  2012-03-17
 

I don’t think the default .htaccess files were ever installed, as this was a clean install and the error started before I had even glanced at the .htaccess files. Odd, all\’s well that ends well

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top