Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem with Magento Transfer and index.php
 
jtroump
Member
 
Total Posts:  49
Joined:  2011-04-11
 

Hi all,
I just transferred my Magento 1.6.1 to a new server and it seems there is a problem with the “index.php” part of my URLs.

Let me give you some details about the transfer process:
1) Uploaded all folders and files to the new server in a folder called “shop”
2) Uploaded the .sql file via phpMyAdmin
3) Changed secure_url and unsecure_url form http://micro-scooters.gr/ to http://microscooters-cyprus.com/shop/
4) Configured the local.xml file
5) Configured the “connect” file in “download” folder
6) Changed the URLs in store views
7) Deleted cache and re-indexed data
8) Cleaned browser cache

The shop seems to work at home page but when I visit a category I get a “The requested URL /shop/default/maxi-micro was not found on this server.”

If I add index.php in the same URL like http://www.microscooters-cyprus.com/shop/index.php/default/maxi-micro/ it works fine.

If I disable URL Rewrite, it adds index.php in URL and works fine.

What I need is to have my URLs work correctly without the index.php like thr shop in the previous server, which by the way is at the same company.

I suppose is something in .htaccess but I cannot find that file in root folder.

Any ideas,please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Benoit Xylo
Member
 
Avatar
Total Posts:  46
Joined:  2009-10-11
Warsaw, Poland
 

Hi resurfacer,

change RewriteBase in your .htaccess file as follows:

RewriteBase /shop/

If you don’t have .htaccess file in your shop root folder then probably you didn’t copy it when transferring your store. In such a case download some Magento installation package, take .htaccess from there and next apply above modification.

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
jtroump
Member
 
Total Posts:  49
Joined:  2011-04-11
 

Yeap, worked like a charm!
Thank you very much, ProSolutio, you saved me a lot of time.

My problem solved with a combination of your advices and the solution provided by this article:
http://www.bestdesigns.co.in/blog/remove-index-php-url-magento

Again, thank you and greetings to beautiful Poland!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mirasvit
Guru
 
Avatar
Total Posts:  639
Joined:  2009-08-22
 

I think. it is more easy to solve using the extension for work with SEO. Try this Advanced SEO Suite http://mirasvit.com/magento-extensions/advanced-seo-suite.html

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top