Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Formulaire contact EasyTabs
 
rivieraferien
Jr. Member
 
Total Posts:  1
Joined:  2012-04-23
 

Bonjours à toutes et à tous,
après de nombreuses recherches qui hélas n’aboutissent à rien, je décide donc d’ouvrir un topic.

Ayant installé le module EasyTabs, j’ai ensuite créé mes onglets voulus (description calendrier prix..), et cela fonctionne très bien.
Mon but étant de créer un onglet “Contact” pour avoir accès au formulaire directement à partir de la page produit.
Et comme avec Easytabs nous pouvons appeler un bloc statique seulement, et non une page cms, je créé donc un bloc statique, et comme décris dans un tuto trouvé sur le net:

- Go to your CMS> Manage Pages interface
- Once there, input your HTML as you normally would on any other page
- Once you are happy with HTML part, add this lines:
<!– CONTACT FORM –>
{{block type="core/template" name="contactForm" form_action="/contacts/index/post" template="contacts/form.phtml"}}
<!– END OF CONTACT FORM –>

Je finis par configurer easytabs, l’onglet Contact apparait bien avec le formulaire de contact.
Le problème est que, lorsque je clic sur le bouton “envoyer” du formulaire, j’abouti sur une page d’erreur qui m’indique:
“Not Found. The requested URL /contacts/index/post was not found on this server”, à l’inverse de la page CMS Contact par défaut de magento, qui, lorsque j’envoie le formulaire, charge un petit peu et finit par mafficher “impossible d’envoyer se mail” car je suis en local, mais cela signifie bien que le formulaire marche par défaut.
J’imagine donc qu’il doit manquer quelque chose, ajouter les simples lignes ci-dessus me parraissait bien trop facile !

Dans le petit tuto ils rajoutent:
“You will notice that we added xml attribute form_action=”/contacts/index/post”. With it we set form action, and your contact form will work properly. Here is how it looks like. Notice the breadcrumbs.”

Et en essayant de supprimer “form_action=”/contacts/index/post” dans la phrase, cela ne marche pas, la page n’abouti sur rien du tout.

Si quelqu’un connait la solution et peut prendre le temps de m’expliquer pas à pas, merci d’avance.
Si cela savère trop compliqué, je suis prêt à rénumérer une personne pouvant me le configurer (c’est l’une des dernières étapes avant la mise en ligne du site).

MERCI d’avance, en espérant avoir des réponses constructives !

Image Attachments
Capture1.PNG
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top