Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade to 0. 7.15480 on 1 & 1
 
dell
Member
 
Avatar
Total Posts:  61
Joined:  2008-01-01
 

Trying to upgrade to latest release following “screen cast” instructions:

http://www.magentocommerce.com/magento-on-the-fly/magento-pear-upgrade-process/

Appeared to only run through a couple of updates and then stopped.  Version still reads 0.7.148

Below is output from Manage Install Extension panel.  If you click on upgrade again it shows “nothing to upgrade”

From:
To :

connect.magentocommerce.com/core Mage_Pear_Helpers 0.7.15480 Beta
pear.php.net Archive_Tar 1.3.2 Stable
pear.php.net Console_Getopt 1.2.3 Stable
pear.php.net PEAR 1.7.0RC2 Beta
pear.php.net Structures_Graph 1.0.2 Stable

I know 1 & 1 has been problematic from the get/go (Ideas?)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

I would guess that original installation was made from complete package, without use of PEAR installation.

See if this applies to you: http://www.magentocommerce.com/boards/viewthread/2913/

 
Magento Community Magento Community
Magento Community
Magento Community
 
dell
Member
 
Avatar
Total Posts:  61
Joined:  2008-01-01
 

Hi Moshe,

Yes, I did the exact changes that Brady did to get 0.7.148 to run on 1 & 1 , watching your thread with him.....thanks for any help.

Del

 
Magento Community Magento Community
Magento Community
Magento Community
 
dell
Member
 
Avatar
Total Posts:  61
Joined:  2008-01-01
 

Moshe,

Have been following thread about this problem here:  http://www.magentocommerce.com/boards/viewthread/2913/

Seems to be at a dead end.  I believe all of us on 1 & 1 shared servers made 9 script changes to 0.7.14800 to get that version to run on 1 & 1 shared hosting.  Those script changes were: swapping ORIG_SCRIPT_NAME for SCRIPT_NAME at 9 locations in:

Mage/Core/Model/Store.php
Mage/Core/Model/Config.php
Mage/Core/Model/Url.php
Mage/Core/functions.php

My question is, could this scripting change be the culprit not allowing the automatic upgrade and/or pear method to upgrade the 0.7.14800 to 0.7.5400?

If it is the problem would you have a thought on how we can accomplish the upgrade without loosing any cart information and resulting in an operational upgraded cart?

appreciate any help

Del

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@dell:
1. Backup your database.
2. Install 0.7.15480 in clean location and point to your existing database during install configuration
3. Make sure your customer configuration is correct in Admin > System > Configuration

This should upgrade the old database structure to new version without loosing the data.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top