Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cannot save payment methods configuration changes in admin area after upgrade to 1.7
 
levelsevenltd
Jr. Member
 
Total Posts:  15
Joined:  2011-04-11
 

Hi,

I recently finished upgrading magento to 1.7 (from 1.4) and now I’m noticing this error whenever I try to save changes made in the payment methods section:

Fatal error: Call to undefined function mcrypt_module_open() in /home/siteaddress/public_html/lib/Varien/Crypt/Mcrypt.php on line 63

I’ve tried checking other sections and found I can save configurations there. Its just the payment section then.

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
KrisCoady
Member
 
Avatar
Total Posts:  39
Joined:  2011-11-08
 

Did you ever get this fixed? I manage multiple Magento webshops that are all unable to save the Payment Methods backend settings since they upgraded to 1.7. I don’t get an error, though. The Save-button just doesn’t do anything anymore.

 
Magento Community Magento Community
Magento Community
Magento Community
 
levelsevenltd
Jr. Member
 
Total Posts:  15
Joined:  2011-04-11
 
kriscoady - 21 September 2012 02:46 AM

Did you ever get this fixed? I manage multiple Magento webshops that are all unable to save the Payment Methods backend settings since they upgraded to 1.7. I don’t get an error, though. The Save-button just doesn’t do anything anymore.

Hi,

I did get it resolved. I had my webhost enable the mcrypt extension I believe magento 1.7 requires. You can use the magento checker to see which components/extensions required are available to magento and use it as checklist. I hear webhosts sometimes have those things turned off so I asked and that solved the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
twoleftfeet
Member
 
Total Posts:  59
Joined:  2008-08-14
 

Hy

@kriscoady:
Could you save the problem? I do have exactly the same problem. I click on the Save-button, but nothing happens.. Updated to 1.7.0.2

 
Magento Community Magento Community
Magento Community
Magento Community
 
kalenjordan
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2011-10-31
Pasadena, CA
 

Interesting.  I ran into this issue the other day and found/updated the solution here:
http://www.magentocommerce.com/boards/viewthread/286198/#t416869

But that actually wasn’t at all related to the mcrypt extension not being installed.  It was related to a known core bug.

@twoleftfeet, you may want to check that out.  Also flip on your logging and go into developer mode so that you’ll at least know exactly what error you’re getting.  If all you’re getting is a blank page, then you can’t be sure what the root cause actually is.

 
Magento Community Magento Community
Magento Community
Magento Community
 
akizor88
Jr. Member
 
Total Posts:  6
Joined:  2011-08-17
 

I encountered the same issue on a fresh Magento 1.7 install. This is how i figured it out (just for future knowledge)
If you are using username/password saving manager inside your browser (Firefox/Chrome/etc) it could cause this issue.

My problem was at Paypal Expres Checkout. Because the tab is not collapsed, i couldn’t see where error was caused. After i opened it, i saw that my browser filled the “email” and “password” field with some random saved credentials. After deletion, everything went back to normal.

It might be the solution in some cases.

Regards smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
yansnay
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2012-04-18
 

My problem was at Paypal Expres Checkout. Because the tab is not collapsed, i couldn’t see where error was caused. After i opened it, i saw that my browser filled the “email” and “password” field with some random saved credentials. After deletion, everything went back to normal.

thanks!

for some reason, some browser autofill this field, so it cant be saved

 
Magento Community Magento Community
Magento Community
Magento Community
 
samzhou
Jr. Member
 
Total Posts:  1
Joined:  2012-03-13
 
akizor88 - 19 March 2013 11:20 AM

I encountered the same issue on a fresh Magento 1.7 install. This is how i figured it out (just for future knowledge)
If you are using username/password saving manager inside your browser (Firefox/Chrome/etc) it could cause this issue.

My problem was at Paypal Expres Checkout. Because the tab is not collapsed, i couldn’t see where error was caused. After i opened it, i saw that my browser filled the “email” and “password” field with some random saved credentials. After deletion, everything went back to normal.

It might be the solution in some cases.

Regards smile

Thanks, mate, I had exactly the same issue, it really blowing my head for 2 days until now.

In my own opinion, the validation process should expand all invalid field tabs, as people don’t even know what’s going on if the invalid fields was hidden, and the save button not responding to any clicks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
joaoverissimo
Jr. Member
 
Total Posts:  4
Joined:  2011-09-12
 

Bati a cabeça com este erro. Antigamente bastava usar o firefox que o botão funcionava corretamente. Porem com uma atualização recente do firefox essa solução deixou de funcionar.

O que acontece é um problema com o modulo do paypal. Me parece que o chrome insere dados nas configurações do paypal.

Para resolver é simples.
1) Na aba de Formas de Pagamento (Sistema > Configuração > Formas de Pagamento);
2) Expanda o módulo PayPal Payment Solutions;
3) Clique no botão Configurações de Pagamento padrão do site (o primeiro botão grande de configurações);
4) Deixe em branco o campo ‘Email Associado com uma Conta Vendedor PayPal’.

Nas lojas que desenvolvo essa solução corrigiu o problema para todas.
Se não funcionar, o erro é por aí…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Appmerce
Guru
 
Avatar
Total Posts:  376
Joined:  2008-05-13
Amsterdam, The Netherlands
 
akizor88 - 19 March 2013 11:20 AM

I encountered the same issue on a fresh Magento 1.7 install. This is how i figured it out (just for future knowledge)
If you are using username/password saving manager inside your browser (Firefox/Chrome/etc) it could cause this issue.

My problem was at Paypal Expres Checkout. Because the tab is not collapsed, i couldn’t see where error was caused. After i opened it, i saw that my browser filled the “email” and “password” field with some random saved credentials. After deletion, everything went back to normal.

It might be the solution in some cases.

Regards smile

PayPal indeed! Chrome added the word “admin” in some field. I guess Chrome tried to enter a user/password automatically when it shouldn’t. Very annoying.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mikesies
Jr. Member
 
Total Posts:  1
Joined:  2012-01-03
 
akizor88 - 19 March 2013 11:20 AM

It might be the solution in some cases.

Regards smile

Hahaha you’re my hero, searched hours for this! Stupid little thing..

 
Magento Community Magento Community
Magento Community
Magento Community
 
evenove
Jr. Member
 
Total Posts:  1
Joined:  2012-07-04
 

Hi,

The solution is easy => Paypal requires an email. If you do not enter an email there, you can’t save all your payment settings…
LOL

Image Attachments
Capture-d’écran-2013-07-16-à-22.56.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
tomschreurs
Jr. Member
 
Total Posts:  1
Joined:  2013-03-13
 

Yes! The ‘PayPal e-mail’ solution works for me as well!

Thank you guys.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top