Magento Forum

   
Problema installazione sample data 1.6 su magento 1.7
 
vehuel
Jr. Member
 
Total Posts:  18
Joined:  2008-09-18
 

Ciao a tutti, è la prima volta che utilizzo magento e ho problemi con l’installazione dei sample data.
Lancio il file sql ma ricevo il seguente errore in phpmyadmin:

Errore
query SQL:

CREATE TABLE `catalog_product_relation` (

`parent_id` INT( 10 ) UNSIGNED NOT NULL DEFAULT ‘0’ COMMENT ‘Parent ID’,
`child_id` INT( 10 ) UNSIGNED NOT NULL DEFAULT ‘0’ COMMENT ‘Child ID’,
PRIMARY KEY ( `parent_id` , `child_id` ) ,
KEY `IDX_CATALOG_PRODUCT_RELATION_CHILD_ID` ( `child_id` ) ,
CONSTRAINT `FK_CAT_PRD_RELATION_PARENT_ID_CAT_PRD_ENTT_ENTT_ID` FOREIGN KEY ( `parent_id` ) REFERENCES `catalog_product_entity` ( `entity_id` ) ON DELETE CASCADE ON UPDATE CASCADE ,
CONSTRAINT `FK_CAT_PRD_RELATION_CHILD_ID_CAT_PRD_ENTT_ENTT_ID` FOREIGN KEY ( `child_id` ) REFERENCES `catalog_product_entity` ( `entity_id` ) ON DELETE CASCADE ON UPDATE CASCADE
) ENGINE = INNODB DEFAULT CHARSET = utf8 ROW_FORMAT = FIXED COMMENT = ‘Catalog Product Relation Table’;

Messaggio di MySQL:

#1005 - Can’t create table ‘ua3xc8k0_open.catalog_product_relation’ (errno: 1478)

qualcuno riesce ad aiutarmi?
grazie

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

su che server lo stai installando? Mi sembra strano che ti dia quell’errore. Prova a riscaricarlo al limite magari il file è corrotto

 
Magento Community Magento Community
Magento Community
Magento Community
 
vehuel
Jr. Member
 
Total Posts:  18
Joined:  2008-09-18
 

ciao,
in locale me lo carica quindi non è corrotto, su joomlahost no

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

Verificato che la versione di mysql sia idonea?

Comunque joomlashost non è proprio il massimo per magento...ma forse stai facendo solo una prova?

Nel caso invece tu stia avviando un e-commerce su quell\\\’host imho è un grave errore:-)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

hai verificato che i requisiti minimi di Magento vengano raggiunti?
http://www.antoniocarboni.com/cms-magento/hosting-per-magento-requisiti-minimi/

 
Magento Community Magento Community
Magento Community
Magento Community
 
vehuel
Jr. Member
 
Total Posts:  18
Joined:  2008-09-18
 

Ciao, ti ringrazio per le risposte.
Si in effetti sto facendo dei test, volevo installare solo una demo
In effetti dal check risulta che:

You need MySQL 4.1.20 (or greater)

Ma è possibile che abbiano una versione di Mysql inferiore alla 4..? mah

Saluti

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3456
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

eh non tutti gli hosting si tengono aggiornati rasberry

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top