Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SSL configuration
 
FernandoOut
Jr. Member
 
Total Posts:  7
Joined:  2012-07-11
 

Hello.
I have two shops at the same server, the two shops are running with Magento under a Bitnami installation.

The urls with /magento like www.myshop.com/magento works fine, but I want to remove /magento from the url.
When I remove it, the pages under https doesn´t work,

Server Rewrite is active.
The index path is /opt/bitnami/apps/magento/htdocs
The configuration of .htcaccess is :

RewriteBase /magento/

---------
The configuration of magento.conf is :

RewriteEngine On
RewriteRule ^/$ / [PT]

¿What can I do?
Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

I am not sure I completely understand what you are asking, but have you tried simply commenting out the following:

RewriteBase /magento/

Like this:

#RewriteBase /magento/
 
Magento Community Magento Community
Magento Community
Magento Community
 
FernandoOut
Jr. Member
 
Total Posts:  7
Joined:  2012-07-11
 

Thanks.
I tried it, but didn´t work.
I only want to remove /magento/ from the secure and unsecure url.
The problems I am encountering is that when I remove /magento/ from the secure and unsecure url, the secure pages brings this error, the unsecure pages works well:

Not Found

The requested URL was not found on this server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Is your domain/server configured with different document roots for the https and non-https hosts?

The only explanation I can think of is that either the files are located in a subfolder named “magento”, or the base url in the admin is set incorrectly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FernandoOut
Jr. Member
 
Total Posts:  7
Joined:  2012-07-11
 
Sindre|ProperHost - 12 August 2012 09:50 PM

Is your domain/server configured with different document roots for the https and non-https hosts?

How can I check this?
All the files are located in this path:

/opt/bitnami/apps/magento/htdocs

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

They are most likely in the same doc root, but you can inspect the settings of the virtual host in the server configuration file (httpd.conf for Apache). Do you run your own server or are you using a hosting company? They may be able to help you out if there is some configuration issue on the server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FernandoOut
Jr. Member
 
Total Posts:  7
Joined:  2012-07-11
 

In the httd.conf file the root is:

DocumentRoot “/opt/bitnami/apps/magento/htdocs”

I am not sure if that is what you mean.

My hosting is Amazon Web Services.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top