Magento Forum

   
Upgrading to 1.7 getting Fatal error: Call to undefined method Varien_Db_Adapter_Pdo_Mysql::dropIndex()
 
nlandman
Jr. Member
 
Total Posts:  3
Joined:  2011-06-27
 

Trying to upgrade from 1.5 to 1.7 using the connect manager.  Pasted in connect20.magentocommerce.com/community/Mage_All_Latest and clicked install think it all went okay, but then found that the maintenance flag file was still in the root.  Deleted the file but now when I hit my site I get the following

Fatal error: Call to undefined method Varien_Db_Adapter_Pdo_Mysql::dropIndex() in /home/flypilot/public_html/app/code/core/Mage/GoogleShopping/sql/googleshopping_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php on line 62

Can\’t find any posts dealing with this message.  I did have the Googleshopping extension on my site, but decided to remove it thinking that would fix the issue, but it has not

If anyone has any suggestions or a post that I missed dealing with this I would appreciate any help.

Thanks

Nick
flypilot.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
michielh
Jr. Member
 
Total Posts:  22
Joined:  2011-03-04
 

Hi,

I had a similar problem but I’m not sure whether it is the same. If found my solution on this spage. I just added /* and */ remarks to the whole file to make sure that no code would be executed and it worked fine afterwards. I reinstated the code after another run and it worked. Hope it does the same for you!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top