Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Creating custom php.ini is resulting a blank home page
 
abousnina
Jr. Member
 
Total Posts:  1
Joined:  2011-09-08
 

Hello,

We want to change max_execution_time and memory_limit and our hosting provider asked us to create our own php.ini

At the start it wasn’t working because of the missing modules, but i’ve enabled everything and magento config checker is saying that everything is ok, but our homepage is blank

FYI : Admin panel is working properly

Please help with this

This is the php.ini that i’m using

; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn’t work

cgi.fix_pathinfo = 1

; adjust memory limit

memory_limit = 256M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects

zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mysql.so
extension=mcrypt.so
extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so
extension=pdo_mysql.so
extension=hash.so
extension=gd.so
extension=dom.so
extension=xmlreader.so
extension=xmlwriter.so
extension=xsl.so
extension=curl.so
extension=iconv.so
extension=php_soap.so

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

You can try to override the values in the .htaccess file instead:

php_value max_execution_time 18000
php_value memory_limit 512M
 
Magento Community Magento Community
Magento Community
Magento Community
 
Cameron_iWeb
Member
 
Avatar
Total Posts:  62
Joined:  2012-03-22
 

Are there any errors written in your log files?

Can you turn on error reporting to see an output?

Thanks

Cameron

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top