Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Paypal Website Payments Pro Issue
 
superdak
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-10-28
 

Setup Info: Running 1.2.0.2 on Cpanel 11.24.4-RELEASE 32603, PHP v5.2.6, MySQL v5.0.67 .  The install is pretty much bone stock except for some minor design changes.

I’m having an issue with Paypal Website Payments Pro (API Signature) not taking orders.  I set up the account info, ran one order and everything went ok.  Ran a second error and got the following popup error:

Invalid Data: The transaction was refused as a result of a duplicate invoice ID supplied.  Attempt with a new invoice ID

So I hit the forums and tried a possible solution.  I cleared out the order info from the following tables in the database:
sales_flat_quote
sales_order
sales_order_entity

Went back to the frontend, ran a test order… worked great.  Ran another test order and got the popup error agian.

I disabled the Payments Pro method and enabled Saved CC.  Ran a few more orders, everything goes smoothly.

So has anyone else had this issue?  I’m 99.99% sure it’s the paypal module not advancing the invoice ID, but what gets me is I know it’s not supposed to advance the ID if the previous order fails, but if the previous order was successfull why would it still not advance the ID?

Any help would be greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
superdak
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-10-28
 

Still having this issue

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top