Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

shipping tablerate che non funziona a dovere - help please! 
 
satboy78
Member
 
Total Posts:  34
Joined:  2009-04-04
 

Ciao a tutti,
ho seguito le istruzioni date in questo topic http://www.magentocommerce.com/boards/v/viewthread/83874/#t291254
ed ho creato un tablerate per le spedizioni, che abbia un prezzo superiore per le isole e uno inferiore per la mia provincia (foggia), ma purtroppo non funziona…

Ecco il mio tablerate:

"Paese","Regione/Stato","Zip/Codice postale","Peso (e superiore)","Prezzo spedizione"
"ITA"
,"*","*",0.0000,7.0000
"ITA","*","*",3.0000,9.0000
"ITA","*","*",10.0000,10.0000
"ITA","*","*",20.0000,12.0000
"ITA","*","*",30.0000,16.0000
"ITA","*","*",50.0000,20.0000
"ITA","*","*",75.0000,24.0000
"ITA","*","07%",0.0000,11.0000
"ITA","*","07%",3.0000,13.0000
"ITA","*","07%",10.0000,15.0000
"ITA","*","07%",20.0000,17.0000
"ITA","*","07%",30.0000,21.0000
"ITA","*","07%",50.0000,25.0000
"ITA","*","07%",75.0000,29.0000
"ITA","*","08%",0.0000,11.0000
"ITA","*","08%",3.0000,13.0000
"ITA","*","08%",10.0000,15.0000
"ITA","*","08%",20.0000,17.0000
"ITA","*","08%",30.0000,21.0000
"ITA","*","08%",50.0000,25.0000
"ITA","*","08%",75.0000,29.0000
"ITA","*","09%",0.0000,11.0000
"ITA","*","09%",3.0000,13.0000
"ITA","*","09%",10.0000,15.0000
"ITA","*","09%",20.0000,17.0000
"ITA","*","09%",30.0000,21.0000
"ITA","*","09%",50.0000,25.0000
"ITA","*","09%",75.0000,29.0000
"ITA","*","71%",0.0000,5.5000
"ITA","*","71%",30.0000,6.5000
"ITA","*","71%",50.0000,9.0000
"ITA","*","71%",75.0000,13.5000

(in allegato c’è anche il contenuto della tabella database)

A me sembra tutto corretto, ma chi prova ad acquistare dalla sardegna (cap 09xxx) o dalla provincia di foggia (cap 71xxx) si vede applicata la spedizione che ho impostato per l’italia in genere

Avete idea del motivo per cui succede questo?

Ho notato che se provo ad esportare il tablerate prima uploadato è leggermente diverso da quello creato da me

Paese,Regione/Stato,"Zip/Codice postale","Peso (e superiore)","Prezzo spedizione"
ITA,*,*,0.0000,7.0000
ITA
,*,*,3.0000,9.0000
ITA
,*,*,10.0000,10.0000
ITA
,*,*,20.0000,12.0000
ITA
,*,*,30.0000,16.0000
ITA
,*,*,50.0000,20.0000
ITA
,*,*,75.0000,24.0000
ITA
,*,07%,0.0000,11.0000
ITA
,*,07%,3.0000,13.0000
ITA
,*,07%,10.0000,15.0000
ITA
,*,07%,20.0000,17.0000
ITA
,*,07%,30.0000,21.0000
ITA
,*,07%,50.0000,25.0000
ITA
,*,07%,75.0000,29.0000
ITA
,*,08%,0.0000,11.0000
ITA
,*,08%,3.0000,13.0000
ITA
,*,08%,10.0000,15.0000
ITA
,*,08%,20.0000,17.0000
ITA
,*,08%,30.0000,21.0000
ITA
,*,08%,50.0000,25.0000
ITA
,*,08%,75.0000,29.0000
ITA
,*,09%,0.0000,11.0000
ITA
,*,09%,3.0000,13.0000
ITA
,*,09%,10.0000,15.0000
ITA
,*,09%,20.0000,17.0000
ITA
,*,09%,30.0000,21.0000
ITA
,*,09%,50.0000,25.0000
ITA
,*,09%,75.0000,29.0000
ITA
,*,71%,0.0000,5.5000
ITA
,*,71%,30.0000,6.5000
ITA
,*,71%,50.0000,9.0000
ITA
,*,71%,75.0000,13.5000

(come potete vedere sono spariti degli “” ad ITA, e ai cap...)

Sto impazzendo, e non ne vengo a capo…

Spero che voi abbiate qualche suggerimento per aiutarmi

Grazie mille.

Image Attachments
tablerate.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top