Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I enable WS-I web services? 
 
jessebarnum
Jr. Member
 
Total Posts:  1
Joined:  2012-07-22
 

I’m new to Magento, and I’m looking into setting up SOAP web services for my client. I’ve set up a new Magento store at http://360works.gostorego.com, but when I go to the WSDL at http://360works.gostorego.com/api/v2_soap?wsdl, it is using RPC-encoded style, not document-literal style.

I’ve seen various references to a setting that you need to change (http://alanstorm.com/magentos_wsi_compliant_api), but I can’t find the actual setting in my store admin. Under the system->configuration menu, there is no Magento Core API choice that I can see. Can you tell me how to switch this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
darksun146
Jr. Member
 
Total Posts:  2
Joined:  2011-07-17
 

System > Configuration

On the left column, you have General, Catalog, ... , Services.

There is no Magento Core API under Services?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top