Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
SOLVED 1/29/2008 - new problem using php5-cgi
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

I figured I’d start a new thread since this appears to be a new problem. I uploaded the php5-cgi to to my cgi-bin folder and had some trouble with that until I saw that I had to 755 that file.  Then I went to the install URL and went through the first few screens. On the download updates page, I clicked the button and the log started scrolling, everything looked ok and a dialog box popped up that said it was successful. After I clicked ok on that dialog, I got this at the URL below:

http://new.mydomain.com/magento/index.php/install/wizard/config/

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

What went wrong? Additionally, if I try to go to the install URL again, the same above error comes up. . .If anyone is wondering, I am on a shared host at Hostrocket…

Apache version 2.0.63
PHP version 5.2.5
MySQL version 5.0.45-community-log
Architecture x86_64
Operating system Linux

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

If you have APC or other bytecode cache enabled, you will need to restart Apache.

If this is not the case, please look in Apache logs for more details.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

I haven’t a clue what that means, I’m not advanced with all this stuff.  All I can do is follow directions and I’m on a shared host so I don’t think I can be doing things like restarting apache......

 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 

I am also having this problem.

I have tried on two hosts - My regular host and GoDaddy.

http://www.medic.ac/magento

http://www.adayinlieu.com/magento

I am using the php5 work around. Everytime I get it working it gets this internal error message.
I spent all yesterday trying to work it out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

It does sound like you might be having a similar problem as mine.  After you got the path in the .htaccess file correct, were you able to get through the first few install screens? It was after the download updates screen and clicking OK in that dialog box that I got the 500 error. And then after that I wasn’t able to run the install again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

I tried it again (had to delete all the magento files and then re-extract them from the archive)
I’ve attached the log file (or as much of it as I could before I got the “all packages were installed successfully, click ok to continue” dialog box)
Once again, as soon as I hit OK, I got the 500 error
When I was looking through the log, it looked like everything was successful except for one thing.  I’m beginning to think Magento is a lost cause, at least this pre-release version. I’d like to test it but not having any luck at all. Will probably just wait until the actual release is out if I haven’t already gone with another shopping cart…

File Attachments
log.txt  (File Size: 3KB - Downloads: 408)
 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 
dax702 - 28 January 2008 04:34 PM

It does sound like you might be having a similar problem as mine.  After you got the path in the .htaccess file correct, were you able to get through the first few install screens? It was after the download updates screen and clicking OK in that dialog box that I got the 500 error. And then after that I wasn’t able to run the install again.

Yeah, I was able to get to the install screen the first time.

It then had all these errors so I tried a fresh install.

That is when I kept getting the 500 internal error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

Yep, only way I could run the installation attempt again was to delete everything and extract the files from the compressed package again, set the folder and file permissions again and then run it, with the same result.

 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 

I just installed the new version.

Still getting the same error

 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 

medic.ac/s is the link to the shop

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

OK, I’ve gotten the solution from my host, I’m just going to cut and paste what they said because it was rather confusing for me to explain and hopefully this will help anyone else with the problem:

Hi Mike,

OK, after backing up your magento folder by copying
it as magento.old I gave the installation process a
shot and this is what I found:

First of all I created a phpinfo.php file within the
new folder and used it to confirm that PHP scripts
running below /new/magento are in fact running under
the php5-cgi binary.

I extracted the archive and ran the installation. I
got the 500 internal server error at the same point
in the process you did. In checking under the Error
Logs icon in your control panel I was able to identify
the error as being caused by group write permissions
being assigned to the Magento index.php file.

I adjusted the permissions of all files under /magento
at that point making them appropriate for a phpSuExec
environment (chmod -R g-w magento & chmod -R o-w magento)
After that /magento/index.php/install/wizard/config/
loaded, however was giving me the \’no iconv/no pdo-mysql\’
errors. Checking /new/magento/.htaccess I saw that the
Magento install had overwritten the file so I again
uncommented the php5-cgi lines.

At this point the Magento setup is again running under
the php5-cgi and seems to be ready to proceed forward.

Sure enough when I put in the install URL, it came right up and asked for the database connection settings and the installation process was successful.  Again, I hope you can make sense of this!

 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 

Still rather confusing rasberry

 
Magento Community Magento Community
Magento Community
Magento Community
 
dax702
Sr. Member
 
Total Posts:  77
Joined:  2008-01-01
las vegas, nv
 

I think that the main issue was something about the permissions on the index.php file, so try changing those.. Wish I could help more.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Yes, that is because your host is using suPHP with a strict permission.

Which means, any chmod permission greater than 755 e.g; 777, on any files or directory, will give you that Internal Server Error.

I guess Magento installer chmods some files to 777 during the install?

Can Varien team confirm this issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
medic
Sr. Member
 
Total Posts:  173
Joined:  2007-10-30
Sydney
 

I think i have put the permissions to 777 on some folders.

I’ll check when I get home.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Clownfish
Jr. Member
 
Total Posts:  2
Joined:  2008-01-28
 

Hello,

had the same error: what worked for me:

chmod the file “/magento/index.php” to 755.

777 is not possible with my host, but 755 worked.

Hope this helps,

Jörg

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2