Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Uploading to a live server has risen quite a few problems
 
alexthebake
Jr. Member
 
Total Posts:  9
Joined:  2012-07-05
 

Hi,

So I’ve been working on this Magento site for some time. I was working on it on my local MAMP server. On the local MAMP server, everything worked exactly as I expected.

Then, I uploaded the site to a live server (using hostgator). Now, a whole bunch of stuff won’t work… and I have no idea why. I’ve tried reinstalling it, and cleaning everything up as much as I can, but things continue to not work.

Here is my site in its current state:
What doesn’t work:
- Add to cart and add to wishlist don’t work. There are no errors, I just click on either of those two, and nothing happens.
- Category Layer Navigation doesn’t work. It won’t show any of the lower layers (again, no errors, it just doesn’t work when I hover over “Products")
- A content-slider using carousel-min.js no longer works. In the Javascript console I get some errors indicating that some variable being passed along is “undefined”

I’m not asking you to go in and fix these problems. I’m wondering if you’ve had similar problems, or if you know why these things won’t work. And why is this happening only after uploading the site onto a live server? Is there some step that I am missing? Some parameter that I need to change? Any help would be greatly, greatly appreciated! Thanks.

UPDATE:
I have noticed for things like the layered navigation, when I hover over “Products” the category tag <ul class="level0"> does not receive the required class “shown-sub”.

This indicates to me that it is a JavaScript problem. Am I right? (I don’t know how magento adds classes to such elements)

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

yes
you need to fix your javascript errors
is it in magento admin or in js folder.

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexthebake
Jr. Member
 
Total Posts:  9
Joined:  2012-07-05
 
MagenX - 23 July 2012 11:16 AM

yes
you need to fix your javascript errors
is it in magento admin or in js folder.

Thank you so much for replying! I feel like my attempts to get help are futile… It’s working now.

I don’t understand how these problems arise though. And I hate that I can never really find the source. Is there some way to ensure that my js is to Magento’s conventions?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top