Magento Forum

   
Cannot add the item to shopping cart. After upgrading to 1.7.0.2 from 1.5.1
 
WetFlam
Jr. Member
 
Total Posts:  25
Joined:  2011-06-16
 

I am getting a error when I try to add an item to my shopping cart which says “Cannot add the item to shopping cart.”

I have deleted all of my shopping cart price rules.
I went to using the default magento theme to rule out theme issues.
Whenever I click add to cart it goes to the shopping cart page and says “Cannot add the item to shopping cart.”
I tried restoring and them upgrading all over again and just got the same issue.
I reindexed all items via the admin panel as well as ssh with no success
I flushed all cache via admin panel and also emptied the cache, sessions, lock folders manually.
I tried creating a new product and get the same error.
I disabled all my modules via the advanced menu in the configuration section.

I have no idea what to do next… There doesnt seem to be any mention of this issue anywhere so I am very worried.

Please help me I have been trying to get past this issue for a total of like 30 hours at this point.

 
Magento Community Magento Community
Magento Community
Magento Community
 
neirauni
Jr. Member
 
Total Posts:  8
Joined:  2011-08-11
 

I also happend with me, still with this error? I upgraded from 1.6.

 
Magento Community Magento Community
Magento Community
Magento Community
 
twierb
Jr. Member
 
Total Posts:  3
Joined:  2011-08-01
 

Same here. My error log says that a column in coupon_x table is missing. I will try the db repair tool now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dickd
Jr. Member
 
Total Posts:  15
Joined:  2010-10-15
 

Check you .htaccess file, mine had links to redirects that did not exsist anymore.
Once i removed them the cart started working and i could access the admin area !!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Borut
Jr. Member
 
Total Posts:  12
Joined:  2008-12-30
 

I had the same issue and I figured out the problem was Magento didn’t have access to /tmp folder. Recently I was changing open_basedir directive in php.ini and after adding /tmp/ to open_basedir problem was solved.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top