Magento Forum

move complete site
 
ZenMasta
Sr. Member
 
Avatar
Total Posts:  108
Joined:  2010-03-12
 

I am trying to copy my live website to a test server

We recently wiped out test server and so I’m trying to dump my live site over there again but so far have been unsuccessful.

Here is my procedure so far assuming I’m in root

live server:

tar -zcvf ../backup.tar.gz --exclude _sd --exclude var/cache --exclude media/catalog/product/cache --exclude media/catalog/product/9/7 --exclude var/log *

life server mysql: I used sqlyog client and dumped the live db directly into the test server, using the copy database to different host feature.

In case you’re wondering why I excluded product images, that dir is about 8GB and I have an extension that will repopulate the catalog images in just a couple of minutes. But images aren’t really important for me in our test bed since we are typically testing extensions or content changes not product imagery smile

test server:
wget mydomain/backup.tar.gz

tar -zxvf backup.tar.gz

vi app/etc/local.xml
change db user db password, leave host the same (localhost)

update
core_config_data
web/unsecure/base_url
web/secure/base_url

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
chmod o+w var var/.htaccess app/etc
chmod 550 pear
chmod -R o+w media

After all this, when I try to load my test site test.mydomain.com
I’m gettin my custom 404 page… as in errors/default

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top