Magento Forum

Mise à jour 1.5.1 ----> 1.7.0.2
 
SINI
Sr. Member
 
Total Posts:  153
Joined:  2009-01-06
 

Bonjour,

Toujours la panade quand on cherche à faire une mise à jour.

Mise à jour faite voici le message d’erreur que j’obtiens lorsque j’essaie mon url de backend :
Précision : magnetoconnect fonctionne et tous les modules sont à jour.et le numérode version en bas de page est la 1.7.0.1

----------

Error in file: “/home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Oauth/sql/oauth_setup/install-1.0.0.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘oauth_consumer’ already exists

Trace:
#0 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘1.0.0.0’)
#2 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb(’1.0.0.0’)
#3 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/ftp/cust_a48/magento/shopv2/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /home/ftp/cust_a48/magento/shopv2/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /home/ftp/cust_a48/magento/shopv2/index.php(87): Mage::run(’’, ‘store’)
#8 {main}

Comment résoudre cette erreur ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ek0892
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2009-10-27
 

idem error

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mageho
Sr. Member
 
Avatar
Total Posts:  291
Joined:  2008-03-24
France, Paris
 

Le message que te retourne MySQL est clair :
SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘oauth_consumer’ already exists

La table oauth_consumer existe déjà.

ça arrive quand le script sql d\’installation/mise à jour est lancé plusieurs fois (par exemple quand tu as 3 clients qui se connecte en même temps)

Pour corriger - pas à pas - je précise, tu te rends là :
app/code/core/Mage/Oauth/sql/oauth_setup/install-1.0.0.0.php

après avoir vérifié que oauth_consumer existe bien dans ton panel d\’administration
tu commentes $adapter->newTable etc etc.

si tu as déjà la table oauth_nonce, tu commentes là aussi.

J\’ai déjà eut ces problèmes plusieurs fois et en faisant comme ça j\’avais réussi mon upgrade.

Cordialement

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top