Magento Forum

   
Reindex broken: Can’t retrieve entity config: catalog/product_index_group_price / Indexer model is not defined. 
 
d0tc0m
Jr. Member
 
Total Posts:  6
Joined:  2011-07-22
 

Hi experts,

After uprading from 1.6.2. to 1.7.0.2 we have an error with re-indexing.

excuting command in ssh: php shell/indexer.php reindexall

ends up with this (errors in red):

Product Attributes index was rebuilt successfully
Can’t retrieve entity config: catalog/product_index_group_price
Catalog URL Rewrites index was rebuilt successfully
Product Flat Data index was rebuilt successfully
Category Flat Data index was rebuilt successfully
Category Products index was rebuilt successfully
Catalog Search Index index was rebuilt successfully
Stock Status index was rebuilt successfully
Tag Aggregation Data index was rebuilt successfully
Indexer model is not defined.

Additionally for some more info we executed this command:  php shell/indexer.php info

ends up with this:

catalog_product_attribute Product Attributes
catalog_product_price Product Prices
catalog_url Catalog URL Rewrites
catalog_product_flat Product Flat Data
catalog_category_flat Category Flat Data
catalog_category_product Category Products
catalogsearch_fulltext Catalog Search Index
cataloginventory_stock Stock Status
tag_summary Tag Aggregation Data
mana_db_replicator
Fatal error: Uncaught exception ‘Mage_Core_Exception’ with message ‘Indexer model is not defined.’ in /home/users/***/***/app/Mage.php:594
Stack trace:
#0 /home/users/***/***/app/code/core/Mage/Index/Model/Process.php(306): Mage::throwException(’Indexer model i...’)
#1 /home/users/***/***/shell/indexer.php(87): Mage_Index_Model_Process->getIndexer()
#2 /home/users/***/***/shell/indexer.php(198): Mage_Shell_Compiler->run()
#3 {main}
thrown in /home/users/***/***/app/Mage.php on line 594

Can anyone shed some light on why this is happening and how we could solve this?

Any help is highly appreciated.

Thanks!

JJ

 
Magento Community Magento Community
Magento Community
Magento Community
 
JustinasLelys
Jr. Member
 
Total Posts:  8
Joined:  2010-04-23
 

Hi, I have same problem after uograding from 1.6.0.0. Have you managed to solve it?

# php shell/indexer.php info
catalog_product_attribute     Product Attributes
catalog_product_price         Product Prices
catalog_url                   Catalog URL Rewrites
catalog_product_flat          Product Flat Data
catalog_category_flat         Category Flat Data
catalog_category_product      Category Products
catalogsearch_fulltext        Catalog Search Index
cataloginventory_stock        Stock Status
tag_summary                   Tag Aggregation Data

# php shell/indexer.php reindexall
Product Attributes index was rebuilt successfully
Can
't retrieve entity config: catalog/product_index_group_price
Catalog URL Rewrites index was rebuilt successfully
Product Flat Data index was rebuilt successfully
Category Flat Data index was rebuilt successfully
Category Products index was rebuilt successfully
Catalog Search Index index was rebuilt successfully
Stock Status index was rebuilt successfully
Tag Aggregation Data index was rebuilt successfully

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alex WM
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2011-02-09
 

Same problem here…

EDIT2: this had to do with an extention: TBT Sweet Points. Problem fixed.

Magento upgrade 1.6.2 to 1.7.0.2 (twice: once by connect, and once by shell --force)
edit: both upgrades from the backup. only time upgraded in the end.

Webshop runs fine, no other issues (extensivly debugged).

Just the Cron reindex-all blocks at catalog_product_index_price_reindex_all

Stacktrace:

exception ‘Mage_Core_Exception’ with message ‘Can’t retrieve entity config: catalog/product_index_group_price’ in /home/users/***/***/app/Mage.php:594
Stack trace:
#0 /home/users/***/***/app/code/core/Mage/Core/Model/Resource.php(272): Mage::throwException(’Can’t retrieve ...’)
#1 /home/users/***/***/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(276): Mage_Core_Model_Resource->getTableName(’catalog/product...’)
#2 /home/users/***/***/app/code/core/Mage/Catalog/Model/Resource/Product/Indexer/Price.php(414): Mage_Core_Model_Resource_Db_Abstract->getTable(’catalog/product...’)
#3 /home/users/***/***/app/code/core/Mage/Catalog/Model/Resource/Product/Indexer/Price.php(469): Mage_Catalog_Model_Resource_Product_Indexer_Price->_getGroupPriceIndexTable()
#4 /home/users/***/***/app/code/core/Mage/Catalog/Model/Resource/Product/Indexer/Price.php(380): Mage_Catalog_Model_Resource_Product_Indexer_Price->_prepareGroupPriceIndex()
#5 /home/users/***/***/app/code/core/Mage/Index/Model/Indexer/Abstract.php(143): Mage_Catalog_Model_Resource_Product_Indexer_Price->reindexAll()
#6 /home/users/***/***/app/code/core/Mage/Index/Model/Process.php(209): Mage_Index_Model_Indexer_Abstract->reindexAll()
#7 /home/users/***/***/app/code/core/Mage/Catalog/Model/Observer.php(244): Mage_Index_Model_Process->reindexAll()
#8 [internal function]: Mage_Catalog_Model_Observer->reindexProductPrices(Object(Mage_Cron_Model_Schedule))
#9 /home/users/***/***/app/code/core/Mage/Cron/Model/Observer.php(115): call_user_func_array(Array, Array)
#10 /home/users/***/***/app/code/core/Mage/Core/Model/App.php(1338): Mage_Cron_Model_Observer->dispatch(Object(Varien_Event_Observer))
#11 /home/users/***/***/app/code/core/Mage/Core/Model/App.php(1317): Mage_Core_Model_App->_callObserverMethod(Object(Mage_Cron_Model_Observer), ‘dispatch’, Object(Varien_Event_Observer))
#12 /home/users/***/***/app/Mage.php(447): Mage_Core_Model_App->dispatchEvent(’default’, Array)
#13 /home/users/***/***/cron.php(46): Mage::dispatchEvent(’default’)
#14 {main}

Cron is showing errors and will partially work. Sceduled cron error on: catalog_product_index_price_reindex_all

Checked database: looking fine. (ref: http://www.magereverse.com/index/magento-database-diagram/version/1-7-0-2)

Can it be fixed?

Anyone?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kalenjordan
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2011-10-31
Pasadena, CA
 

Hey @Alex, have you contacted Sweet Tooth support?  I actually happen to work for them smile We have pretty good support and should be able to determine whether the cron issue is being caused by our module.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alex WM
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2011-02-09
 

@mageupdate: You have an excellent support smile

Actually: you guys have it fixed before I could blink. Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
kalenjordan
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2011-10-31
Pasadena, CA
 

Thanks smile Ya Sweet Tooth has one of the best support teams in the industry for sure.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top