Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Orders with invalid credit card numbers are present in order table and admin. 
 
sgarg7
Jr. Member
 
Total Posts:  4
Joined:  2012-06-21
 

Hi,

My problem happens on the last step of ordering an item - the order review section. If wrong credit card details were entered eg. wrong CVN, and “place order” is pressed, the alert message saying “Gateway error. The credit card number is invalid.” shows up and the order stays at the same place on the website, but the record has been inserted in the database in the tables sales_flat_order and sales_flat_order_payment.

This order is different from the processed and validated orders.. there are no comments saying the credit card information was captured and validated or that email confirmation sent to client. However it is an order that is present as a completed order. It shouldn’t be present.

Where do you guys think the issue is? This issue has been happening since we did a backup restore of our server.

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top