Magento Forum

Payflow Pro Integration
 
WinginIt
Member
 
Total Posts:  43
Joined:  2008-12-12
 

This issue has been addressed, but I can not find resolution.

I can operate the “virtual terminal” in PayPal Manager just fine.  Our money gets to us.

How has anyone made Payflow Pro actually work in “Checkout”?

I continue to get the thrown exception - “User Authentification Error”.  I have talked to the technical guys at PayPal 3 times to make sure that the protocol is the same as I am using in the admin backend to configure the Payment Method.  (Have checked for spaces and case sensitive matches) I have read config and system.xml’s, Pro.php. Abstract.php and Cc.php and more.  I have compared my Version 1.0 files to the newest files in 2.+.  (There are some changes.)

Are there Port issues or Proxy or Host issues that I should know about?

The “request” appears to be going with everything labeled correctly and thoroughly (database-debug).

Has everyone given up on this?  I am not finding any answers and I hate like hell to pass this over to someone on the outside after I have already spent so much time on it, and am already somewhat familiar with the files. 

Was thinking of starting over with my own “new version” of the gateway to see what would happen.  Any suggestions?  Has anyone overcome these issues, or are we just paying PayPal for services that we can’t use? 

Please, can someone help me find the way?!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mik
Jr. Member
 
Total Posts:  12
Joined:  2008-04-29
 

Just out of curiosity are you sure you want to use Payflow Pro and not PayPal direct? We were also having a very hard time configuring integration but managed to get it tweaked and working last night. The main issue was that PayPal Sandbox did not operate correctly with Magento making you think PayPal as a whole was not compatible. Once I put it into live mode we seem to have it working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cpx333
Jr. Member
 
Total Posts:  4
Joined:  2009-01-16
 

We were recently having the same ‘User Authentication Error’ but corrected it today. I am hoping our solution will help you. If your Payflow Pro user name or password has any symbols ~!@#$%^&*() in it this may be causing the token sent to Payflow Pro to become truncated after the symbol(s) in the user name or password, which would be the cause for the user authentication error. Go into your PayPal manager and create a new user login and password without any symbols; with numbers and letters only. Then in Payflow Pro setup in Admin, keep the vendor the same as your main login for PayPal. Change the user name to the new one you created. Do the same for the password. Run a test transaction and hopefully you will not receive the error message.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WinginIt
Member
 
Total Posts:  43
Joined:  2008-12-12
 

To MIK and cpx333...Thank you for responding to my dilemma.  I apologize for not thanking you for your presence sooner......I went on strike with the PayPal issue....just didn’t want to look at it for a few days.

None of my login / user / pw contained symbols.  And, I eschewed the Sandbox because the account was already in existence, and active for both test and live transactions.  (And had read of Sandbox problems in the forum, anyway.)

I had changed the url in config from the original set url (payflowpro.verisign.com/transaction) to payflowpro.paypal.com.  This was on the recommendation of PayPal and posts in the forum.  I went back to the old url today since we have until Sept. 09 to make sure we are using V4 SDK.  This PP account was set up years ago, for an original site, but never integrated.  (I just came along a few months ago.) I doubt that was the offending issue, as that was one of the things I kept altering when I was getting the errors.

I recommend anyone with mysterious issues, check and double-check the permitted IP addresses in PayPal Manager if there have been some put in place. 

(FROM PayPal Merchant Technical Services) “Allowed IP Address security feature implemented”:

“The Allowed IP Address security feature blocks all transactions coming from IP addresses that are not included in the approved list. This generates the “User Authentication Failed” error because the IP address is not valid.

- Verify that the IP address(es) entered in PayPal Manager are static and correct. However, even though you set the IP address to a static IP given to you by your hosting company, the error occurs if your web server is not on a single static IP. Your web site may be hosted on a web/server farm that allows the hosting company to define your web site as a virtual server.
- To allow a server farm access to your Payflow account via the ‘Allowed IP Address’ option, contact your hosting company to obtain the IP addresses or range of addresses that your web site is using.
- Type the IP addresses in the approved list under Allowed IP Address.”

There are so many of us having problems with this gateway.  When someone “gets it,” the solution doesn’t work for another.  I think the IP addresses were my problem.  This might steer someone else - hope so.  Would like to return the favor.

Thank you again for responding.  Much appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fishnut
Member
 
Total Posts:  45
Joined:  2008-11-15
 

THANK YOU THANK YOU THANK YOU!!!!  I updated to 1.2.0.2 over the weekend and since then my payflow pro has not worked and has given me the “user authentication failed” error.  I have a few stores and the two I upgraded didn’t work while the one I didn’t upgrade still worked, all with the same login and I couldn’t find anything on the error.

I changed my password and took out the symbol and it works, Thanks for your post!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ForgetHangovers
Sr. Member
 
Total Posts:  83
Joined:  2009-04-12
Maryland, USA
 
WinginIt - 20 January 2009 12:52 PM

I had changed the url in config from the original set url (payflowpro.verisign.com/transaction) to payflowpro.paypal.com.

I had the same problem, Thanks for the fix WinginIt.

Any idea why Magento comes defaulted to “payflowpro.verisign.com/transaction” instead of the correct URL (payflowpro.paypal.com) ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top