Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Receiving message “Can’t retrieve entity config: salesrule/website” on frontend
 
bfamous
Jr. Member
 
Total Posts:  4
Joined:  2010-01-07
 

Greetings,
i just finished upgrading my site from 1.6.0 to 1.7.0, and after a full day of fighting with it, i think i’m almost 80% of the way there.
However, now whenever i try to add a product to my cart, i receive the following message at the to of the page and the item does not get added:

Can’t retrieve entity config: salesrule/website

I also receive a similar message pretty much whenever i try to edit a product in the admin:

Can’t retrieve entity config: catalogrule/website

Can anyone tell me where these settings are declared, or what i need to do in order to correct the issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
toddfletcher
Jr. Member
 
Total Posts:  1
Joined:  2012-05-17
 

BUMP!

I am getting the same error after upgrading to the later 1.7. Any ideas on a solution?!

Getting \\\"Can\\\’t retrieve entity config: salesrule/website\\\” if I try to add an item to the cart.

 
Magento Community Magento Community
Magento Community
Magento Community
 
apeshit
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2011-01-18
 

Hello-

I too had the same error message

Can’t retrieve entity config: salesrule/website

after upgrading to 1.7.0 from 1.5 or 1.6.

I was also having trouble finding and logging into my custom named admin panel, which I finally figured out how to fix after reading this article: http://www.magentocommerce.com/boards/viewthread/68743/

After deleting my cache, as it states in that article, I know longer get the

Can’t retrieve entity config: salesrule/website

message. So try deleting your cache, which is located in the VAR/CACHE folder.

Thanks and I hope this helps because I know how frustrating it can be trying to find solutions for problems that arise in Magento, especially after upgrading.

Good Luck!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top