Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Show code in Magento Wordpress Integration
 
gizmocn
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2007-09-13
Xi'an, China
 

I want to show code in Magento CMS page, I use:

<pre>

<img src="{{skin url=images/demo/1.jpg}}” alt="” />

</pre>

but the results is

<img src="http://www.rogerwatch.com/skin/frontend/base/default/images/demo/1.jpg" alt="” />

The “{{skin url=” was replaced by url, how can I prevent it.

Thanks in advanced.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kab8609
Moderator
 
Avatar
Total Posts:  821
Joined:  2009-04-07
Cleveland
 

Your post lacks details, so I’m assuming you are using the Fishpig Wordpress/Magento integration extension.

You also need to install this extension too: http://www.magentocommerce.com/magento-connect/syntax-highlighter.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
gizmocn
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2007-09-13
Xi'an, China
 

Yes, I use Fishpig Wordpress/Magento integration extension and I do test their anther extension: http://www.magentocommerce.com/magento-connect/syntax-highlighter.html

but the results is same, I am running a template site in China, I want to put template installation instrucion in my blog(Magento with Fishpig Wordpress extension), but the code always convert actual url even I have syntax highlighter extension installed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kab8609
Moderator
 
Avatar
Total Posts:  821
Joined:  2009-04-07
Cleveland
 

Looking at http://alexgorbatchev.com/SyntaxHighlighter/manual/brushes/

You need to have it named like this: <pre class="brush: xml;">

As you stated, you only have <pre>

This is working on my 1.7 Magento site

 
Magento Community Magento Community
Magento Community
Magento Community
 
gizmocn
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2007-09-13
Xi'an, China
 

Thanks Kris, but it is not work for me and another problem is that Syntax Highlighter Extension are not compatible with my theme

I just need a simple way to show Magento code in plain text in Magento Fishpig Wordpress Intergration, like:

<div id="section1" class="sectionslide">
<a href="{{store direct_url="#"}}"><img src="{{skin url="images/slider/slider1.jpg"}}" alt="” /></a>
</div>

Anyone can hep me, thanks in advanced.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kab8609
Moderator
 
Avatar
Total Posts:  821
Joined:  2009-04-07
Cleveland
 
gizmocn - 02 August 2012 06:23 AM

Thanks Kris, but it is not work for me and another problem is that Syntax Highlighter Extension are not compatible with my theme

I just need a simple way to show Magento code in plain text in Magento Fishpig Wordpress Intergration, like:

<div id="section1" class="sectionslide">
<a href="{{store direct_url="#"}}"><img src="{{skin url="images/slider/slider1.jpg"}}" alt="” /></a>
</div>

Anyone can hep me, thanks in advanced.

Well first, have you verified it working on the base theme from Magento? If so, then the next step is to see why it isn’t working on your theme. It could be a .js or a .css. Maybe its not finding the file. Is it displaying any errors? If so, what are they? Turn on logging as well and see if that spits anything out. Then report back.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top