Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Orders visible in Database but not in Magento Admin after 1.7 Upgrade
 
Sajid iqbal
Jr. Member
 
Total Posts:  14
Joined:  2009-12-08
 

Hi,

After going through a painful process I was able to upgrade my old 1.4 magento to brand new 1.7. Now I have this last glitch with upgrade which I am unable to resolve so far. The problem is if I browse sales_order table I am able to see all orders over there but not in magento admin. Only 178 most recent orders are showing up while actual figure is 3500+. Has anyone faced this problem and was able to solve it?

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sajid iqbal
Jr. Member
 
Total Posts:  14
Joined:  2009-12-08
 

Following are the screenshots of admin and db(in phpmyadmin).

Image Attachments
db.pngadmin.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sajid iqbal
Jr. Member
 
Total Posts:  14
Joined:  2009-12-08
 

Ok,

What i have found is the 172 orders it is showing are from sales_flat_orders....I am really confused since 1.4 had same structure with few orders stored in sales_flat_orders and others in sales_orders but they are shown up in Admin without any problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RB2009
Member
 
Total Posts:  40
Joined:  2010-12-05
 

did you use the old encryption key when you upgraded or rely on magento to generate a new one?

long key like this?

q1q254q5157785b037145b46cdfb2424

if you did, find out what the old one was from your old local.xml file.

located in,

App/etc/

copy the key, then change the current local.xml file by updating that key with the old one.

I think its a security thing, if the encryption key changes then you cant access the orders and things.

Also, doing a version jump that big, I recommend you use the Magento Database Repair tool to compare your 1.7 production database to a clean 1.7 database to check for any problems and fix it smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sajid iqbal
Jr. Member
 
Total Posts:  14
Joined:  2009-12-08
 

Thanks for the reply.

Tried your tip but didn’t work for me. In fact encryption key was correct already. The problem is their are 172 very first orders are shown there but not all others.

RB2009 - 10 July 2012 07:44 PM

did you use the old encryption key when you upgraded or rely on magento to generate a new one?

long key like this?

q1q254q5157785b037145b46cdfb2424

if you did, find out what the old one was from your old local.xml file.

located in,

App/etc/

copy the key, then change the current local.xml file by updating that key with the old one.

I think its a security thing, if the encryption key changes then you cant access the orders and things.

Also, doing a version jump that big, I recommend you use the Magento Database Repair tool to compare your 1.7 production database to a clean 1.7 database to check for any problems and fix it smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sajid iqbal
Jr. Member
 
Total Posts:  14
Joined:  2009-12-08
 

What I have learned so far that Magento no more store orders in sales_order but sales_flat_orders. During the upgrade the table data is not copied to newly created sales_flat_order.
Interestingly, the orders showing up in backend are the one’s loading from sales_flat_orders. Now I am really confuse what went wrong. Can anybody help?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top