Magento Forum

   
Zend_Db_Adapter_Mysqli_Exception Object
 
Mefmind
Jr. Member
 
Total Posts:  13
Joined:  2007-11-27
 

I was using my site fine yesterday but i went to bring it up today and this is what I get. I cant even access the admin page.

Zend_Db_Adapter_Mysqli_Exception Object
(
[_chainedException:protected] =>
[message:protected] => Level2:Incorrect information in file: ‘./savecp_usaveabuck/review_store.frm’
[string:private] =>
[code:protected] => 0
[file:protected] => /home/savecp/public_html/lib/Varien/Db/Adapter/Mysqli.php
[line:protected] => 154
[trace:private] => Array
(
[0] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 423
[function] => multi_query
[class] => Varien_Db_Adapter_Mysqli
[type] => ->
[args] => Array
(
[0] => delete from review_store;
insert into review_store select review_id, 1 from review;
)

)

[1] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 210
[function] => run
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => delete from review_store;
insert into review_store select review_id, 1 from review;
)

)

[2] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 135
[function] => _modifyResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => upgrade
[1] => 0.6.1
[2] => 0.6.3
)

)

[3] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 101
[function] => _upgradeResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => 0.6.1
[1] => 0.6.3
)

)

[4] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php
[line] => 84
[function] => applyUpdates
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
)

)

[5] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/Config.php
[line] => 135
[function] => applyAllUpdates
[class] => Mage_Core_Model_Resource_Setup
[type] => ::
[args] => Array
(
)

)

[6] => Array
(
[file] => /home/savecp/public_html/app/code/core/Mage/Core/Model/App.php
[line] => 126
[function] => init
[class] => Mage_Core_Model_Config
[type] => ->
[args] => Array
(
[0] =>
)

)

[7] => Array
(
[file] => /home/savecp/public_html/app/Mage.php
[line] => 359
[function] => init
[class] => Mage_Core_Model_App
[type] => ->
[args] => Array
(
[0] => base
[1] =>
)

)

[8] => Array
(
[file] => /home/savecp/public_html/app/Mage.php
[line] => 379
[function] => app
[class] => Mage
[type] => ::
[args] => Array
(
[0] => base
[1] =>
)

)

[9] => Array
(
[file] => /home/savecp/public_html/index.php
[line] => 28
[function] => run
[class] => Mage
[type] => ::
[args] => Array
(
[0] => base
)

)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Looks like ‘review_store’ table is corrupted.
This happens, run in the Mysql console:

REPAIR TABLE review_store;
It is possible you have other tables corrupted.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top