Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
PHP Extensions “0” must be loaded , while installing magento-1.7.0.1.tar.bz2
 
afinnarn
Jr. Member
 
Total Posts:  1
Joined:  2013-04-28
 

I just tried the workaround mentioned above for Magento 1.7.0.2:

<extensions>
  <
pdo_mysql>1</pdo_mysql
</
extensions>

and it worked. If you get a “database connection error” code, make sure the databse you are trying to connect to exists. Once I created a MySQL database and linked to it on that screen, it worked fine. The username and password relate to connecting to that databse and not to creating a user account, like I had originally thought.

 
Magento Community Magento Community
Magento Community
Magento Community
 
letmovedev
Jr. Member
 
Total Posts:  10
Joined:  2013-05-06
 

Work well for me in Ubuntu 13.04. Thanks guy

 
Magento Community Magento Community
Magento Community
Magento Community
 
ByScripts
Jr. Member
 
Total Posts:  1
Joined:  2013-05-21
 

Same problem here.

After spending minutes to try to make it works, I decided to install Prestashop, which is working fine.

Don\’t want to modify a core file to make the installation works (actually I did it to be sure… but I\’m not \"ok\" with this kind of method)

Nice shot Magento… not being able to solve such a problem after 1 year… don\’t sure you deserve my trust…

What will happens if my shop encouter another bug ... which will not be solved before years ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moullablad
Jr. Member
 
Total Posts:  1
Joined:  2009-07-18
 

its juste about the version of PHP used by apache i am using mac with mamp software i changeged the version of php from preferences of mamp i used 5.2 and all is working fine its not related with pdo or anything because the error is zero so i don’t know why some peoples said pdo and all friends has not fixed the issue, its ok now just change the version of php to 5.2 an all will work perfectly.

Brahim Moullablad
http://www.moullablad.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
my3d
Jr. Member
 
Total Posts:  2
Joined:  2013-02-15
 

I had the same problem and I was using PHP 5.4 and went back to PHP 5.3 and didn’t get the same error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
prabath321
Jr. Member
 
Total Posts:  3
Joined:  2008-07-14
 

<extensions>
    <
pdo_mysql>1</pdo_mysql>
</
extensions>

work for me ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
weboyjack
Jr. Member
 
Total Posts:  1
Joined:  2013-06-16
 

Wow! It works.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CGI TW
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2009-12-03
Hannover - Bemerode
 

Hi everybody,

there is also an open PHP bug: https://bugs.php.net/bug.php?id=62639
But as I see the it hasn’t high priority for now and the bug is already long time open.

Greetings smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
shane12345
Jr. Member
 
Total Posts:  4
Joined:  2012-12-22
 

adding the “1” in the Xml file worked for me. Why the hell is this still an issue? I remember dealing with this a way long time ago.

 
Magento Community Magento Community
Magento Community
Magento Community
 
svenvarkel
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2011-11-29
Tallinn, Estonia
 

The bug is still there in PHP 5.5 also. All Magento developers/maintainers could go to https://bugs.php.net/bug.php?id=62639 and vote for this bug to get fixed faster. Really annoying.

There’s also a workaround to that but it depends on your workflow.

When you’re using workflow with BitBucket/GitHub and a skeleton Magento then you can fix it in your skeleton and it would get propagated to your new Magento deployments.

 
Magento Community Magento Community
Magento Community
Magento Community
 
evilronin
Jr. Member
 
Total Posts:  1
Joined:  2013-05-22
 

This code correction didn’t work for me at first and was very frustrating. Then I saw on this guy’s blog Theneum. He posted this code correction in the 70th line, which again, didn’t really work for me. But he added after doing this correction not to go back to localhost:8888, go to instead 127.0.0.1:8888/magento/ this worked for me. Theneum’s explanation was that “something to do with no periods in the domain”. So I hope this helps some people who are still getting this dreaded PHP Extension error during install. Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2