Magento Forum

Page 1 of 2
PHP Extensions “0” must be loaded , while installing magento-1.7.0.1.tar.bz2
 
odf4ever
Jr. Member
 
Total Posts:  2
Joined:  2012-06-20
 

I unpacked magento-1.7.0.1.tar.bz2 and magento-check.zip. Running magento-check results in success.
Running the install wizard gets stuck at “Configuration”. After filling in the fields it returns with
PHP Extensions “0” must be loaded.
$resource->getRequiredExtensions() returns Array ( [0] => 0 ), which results in the error.

Further debugging showed me how huge the code base is => hope this is quicker :-)

 
Magento Community Magento Community
Magento Community
Magento Community
 
jeremy23
Jr. Member
 
Total Posts:  2
Joined:  2012-06-21
 

I am getting the same issue. I was able to work around it by modifying getRequiredExtensions() to “return Array();”.

I have reported the issue at: http://www.magentocommerce.com/bug-tracking/issue?issue=13827

(Unfortunately the bug tracker decided to truncate the title of the bug.)

 
Magento Community Magento Community
Magento Community
Magento Community
 
mitevjoro
Jr. Member
 
Total Posts:  1
Joined:  2012-06-21
 

I have got the same issue. I have tested and reproduced with 1.7.0.1 and with 1.7.0.0 versions.
Any workaround?

 
Magento Community Magento Community
Magento Community
Magento Community
 
odf4ever
Jr. Member
 
Total Posts:  2
Joined:  2012-06-20
 

Using version 1.7.0.1, in file
./app/code/core/Mage/Install/Model/Installer/Db.php
after line 64 (foreach ($extensions as $extName) {) , I added:
if($extName == 0) continue;

Since this is my first encounter with Magento I have no clue if the results are ok after the setup with this work around.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vsushkov
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2010-07-27
Russia, Taganrog
 

The problem seems to be in wrong version PHP SimpleXML extension. Here’s another workaround:

Replace in file app/code/core/Mage/Install/etc/config.xml (near 71th string) this

<extensions>
    <
pdo_mysql/>
</
extensions>

with this

<extensions>
    <
pdo_mysql>1</pdo_mysql>
</
extensions>
 
Magento Community Magento Community
Magento Community
Magento Community
 
ink_ru
Jr. Member
 
Total Posts:  1
Joined:  2012-10-09
 
vsushkov - 17 July 2012 11:32 AM

The problem seems to be in wrong version PHP SimpleXML extension. Here’s another workaround:

Replace in file app/code/core/Mage/Install/etc/config.xml (near 71th string) this

Thanks all works smile, but why this bug still not fixed :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
robbora
Jr. Member
 
Total Posts:  1
Joined:  2012-10-22
 

Unfortunately this doesn’t work for me. Browser (Firefox in my case) gave me the error “this page isn’t redirecting properly”

vsushkov - 17 July 2012 11:32 AM

The problem seems to be in wrong version PHP SimpleXML extension. Here’s another workaround:

Replace in file app/code/core/Mage/Install/etc/config.xml (near 71th string) this

<extensions>
    <
pdo_mysql/>
</
extensions>

with this

<extensions>
    <
pdo_mysql>1</pdo_mysql>
</
extensions>

So now i’m trying with this solution and it seems to be working at the moment (Magento version i’m using is 1.7.0.2)

odf4ever - 22 June 2012 01:56 AM

Using version 1.7.0.1, in file
./app/code/core/Mage/Install/Model/Installer/Db.php
after line 64 (foreach ($extensions as $extName) {) , I added:
if($extName == 0) continue;

Since this is my first encounter with Magento I have no clue if the results are ok after the setup with this work around.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mace5805
Jr. Member
 
Total Posts:  1
Joined:  2012-10-25
 
robbora - 23 October 2012 12:51 AM

Unfortunately this doesn’t work for me. Browser (Firefox in my case) gave me the error “this page isn’t redirecting properly”

vsushkov - 17 July 2012 11:32 AM
The problem seems to be in wrong version PHP SimpleXML extension. Here’s another workaround:

Replace in file app/code/core/Mage/Install/etc/config.xml (near 71th string) this

<extensions>
    <
pdo_mysql/>
</
extensions>

with this

<extensions>
    <
pdo_mysql>1</pdo_mysql>
</
extensions>

So now i’m trying with this solution and it seems to be working at the moment (Magento version i’m using is 1.7.0.2)

odf4ever - 22 June 2012 01:56 AM

Using version 1.7.0.1, in file
./app/code/core/Mage/Install/Model/Installer/Db.php
after line 64 (foreach ($extensions as $extName) {) , I added:
if($extName == 0) continue;

Since this is my first encounter with Magento I have no clue if the results are ok after the setup with this work around.

I was able to determine that in order for the first posted solution to work, you have to enable pdo_mysql on your server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tim_
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-11-06
Netherlands
 
odf4ever - 22 June 2012 01:56 AM

Using version 1.7.0.1, in file
./app/code/core/Mage/Install/Model/Installer/Db.php
after line 64 (foreach ($extensions as $extName) {) , I added:
if($extName == 0) continue;

Since this is my first encounter with Magento I have no clue if the results are ok after the setup with this work around.

Thanks! This worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Shirokovskiy
Jr. Member
 
Avatar
Total Posts:  28
Joined:  2010-10-21
Russian Federation
 

pdo_mysql is installed
on another comp I never saw this error
Start to work on x64 machine, all same installations (mcrypt, curl, etc.) - now have the same error.
Weird.
Fixed with pdo_mysql tag with 1 value inside - works

<pdo_mysql>1</pdo_mysql>
 
Magento Community Magento Community
Magento Community
Magento Community
 
jonathanjb
Jr. Member
 
Total Posts:  1
Joined:  2013-01-09
 

Thanks. It worked with me too. I’m using Magento 1.7.0.2.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tech0925
Member
 
Avatar
Total Posts:  56
Joined:  2011-08-15
Alabama
 

That work around does work. However, if you have access to update your apache settings and etc. I found that simply adding the MySQLi extension fixes this issue :)

 
Magento Community Magento Community
Magento Community
Magento Community
 
imkt
Jr. Member
 
Total Posts:  1
Joined:  2012-06-18
 

Worked out perfectly.. I changed browsers to Safari… it worked just fine THANKYOU VVM..

 
Magento Community Magento Community
Magento Community
Magento Community
 
arlejeun
Jr. Member
 
Total Posts:  1
Joined:  2013-02-17
 

Thanks, work for me !

 
Magento Community Magento Community
Magento Community
Magento Community
 
edwilliams
Jr. Member
 
Total Posts:  1
Joined:  2013-03-15
 

with 7.0.1.2, I have tried the following solutions as above:

extensions>
        <
pdo_mysql/>
    </
extensions>

    
with this

    
<extensions>
        <
pdo_mysql>1</pdo_mysql>
    </
extensions>

...and…

./app/code/core/Mage/Install/Model/Installer/Db.php
    after line 64 
(foreach ($extensions as $extName{) , I added:
    if(
$extName == 0) continue;

neither work, I still get PHP Extensions “0” must be loaded. or, with the solutions above, i get database connection error.

is there anything left to try?

Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
boxrec
Jr. Member
 
Total Posts:  8
Joined:  2008-10-27
 

Bump - same problem and none of the solutions worked for me :-(

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2