Magento Forum

   
PEAR error; No releases available, cannot initialize, unknown channel? 
 
driftin
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2007-12-21
 

I’m following the magento project for a while now, and i decided to give it a try to install. But when i’ve got everything configured like the install guide says, i get this error.

My config uses the php5-cgi file, and i’ve set all the right permissions for the files. So I dont know whats going on? Someone?

EDIT: http://magento.driftin.nl/phpinfo.php ,and using the latest build 0.7.14800

Setting preferred state tobeta

config
-set succeeded
Downloading 
and installing Magentoplease wait...

No releases available for package "pear.php.net/PEAR"
Cannot initialize 'channel://pear.php.net/PEAR-stable'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Mage_Pear_Helpers"
invalid package name/package file "connect.magentocommerce.com/core/Mage_Pear_Helpers"
Cannot initialize 'connect.magentocommerce.com/core/Mage_Pear_Helpers'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Lib_ZF"
invalid package name/package file "connect.magentocommerce.com/core/Lib_ZF"
Cannot initialize 'connect.magentocommerce.com/core/Lib_ZF'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Lib_Varien"
invalid package name/package file "connect.magentocommerce.com/core/Lib_Varien"
Cannot initialize 'connect.magentocommerce.com/core/Lib_Varien'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Mage_All"
invalid package name/package file "connect.magentocommerce.com/core/Mage_All"
Cannot initialize 'connect.magentocommerce.com/core/Mage_All'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Interface_Frontend_Default"
invalid package name/package file "connect.magentocommerce.com/core/Interface_Frontend_Default"
Cannot initialize 'connect.magentocommerce.com/core/Interface_Frontend_Default'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Interface_Adminhtml_Default"
invalid package name/package file "connect.magentocommerce.com/core/Interface_Adminhtml_Default"
Cannot initialize 'connect.magentocommerce.com/core/Interface_Adminhtml_Default'invalid or missing package file
Attempting to discover channel 
"connect.magentocommerce.com/core"...
unknown channel "connect.magentocommerce.com/core" in "connect.magentocommerce.com/core/Interface_Install_Default"
invalid package name/package file "connect.magentocommerce.com/core/Interface_Install_Default"
Cannot initialize 'connect.magentocommerce.com/core/Interface_Install_Default'invalid or missing package file
Array
(
    
[data] => Array
        (
            
[0] => Array
                (
                    
[0] => Package "channel://pear.php.net/PEAR-stable" is not valid
                
)

            
[1] => Array
                (
                    
[0] => Package "connect.magentocommerce.com/core/Mage_Pear_Helpers" is not valid
                
)
                
[....etc etc...]
    [headline] 
=> Install Errors
)


PEAR ERRORinstall failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
driftin
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2007-12-21
 

*** little kick***

I’ve been digging up my error logs but couldn’t find anything in there...?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Scott
Guru
 
Avatar
Total Posts:  333
Joined:  2007-08-31
Northwest Ohio
 

driftin, sorry no one has replied, as this seems to be a common issue.

The fix should be to chmod the magento/lib/pear directory to 777 recursively (-R). That did the trick for me anyway. Hope it works for you! wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
driftin
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2007-12-21
 

Nope, I’ve already tried that… Doesnt work, gives the same error output.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xinhaozheng
Sr. Member
 
Total Posts:  107
Joined:  2009-03-09
 

you may try reinitialize pear config file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
incredimike
Jr. Member
 
Total Posts:  8
Joined:  2009-12-04
 

This is exactly what you need to do.

chmod -R 777 magento/lib/pear
./pear mage-setup
./pear download [Connect 1.0 Key]

Voila.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top