Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

After 1.1.8 -> 1.2.0 - 1.2.0.1 update: SQLSTATE[HY000]: General error: 1271 Illegal mix of collations for operation ‘UNION’
 
royaleshops
Jr. Member
 
Total Posts:  20
Joined:  2008-07-17
 

I get this error:

SQLSTATE[HY000]: General error: 1271 Illegal mix of collations for operation ‘UNION’

when trying to add new product or edit existing.

When i add pictures - it doesn’t give no error after upload - but the frame where the picture should be - disappears when mouse rolls over.

I have reinstalled AdminHTML as suggested in another post - but this didn’t work for me.

Any suggestions ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
rainman127
Sr. Member
 
Avatar
Total Posts:  218
Joined:  2008-06-30
 

Sounds like some of your database tables are InnoDB and some are MyISAM.
I believe all should be innoDB

 
Magento Community Magento Community
Magento Community
Magento Community
 
royaleshops
Jr. Member
 
Total Posts:  20
Joined:  2008-07-17
 

You are right !

I have changed (found the command in another post) all but

SQL query: Edit

ALTER TABLE `catalogsearch_fulltext` ENGINE = innodb

MySQL said: Documentation
#1214 - The used table type doesn’t support FULLTEXT indexes

I have asked my provider for a solution but if anyone have a good idea ...

The annoying part is that i keep my Magento absolutely standard :-(

 
Magento Community Magento Community
Magento Community
Magento Community
 
.: Ziad :.
Jr. Member
 
Total Posts:  1
Joined:  2009-08-23
 

hello royaleshops,

i faced this problem before, but in my case it was because that i changed the attribute type of the colomun “value” in table “catalog_product_entity_varchar” from utf8_general_ci to utf8_unicode_ci.

when i turn it back to utf8_general_ci, the error disappeared!

are you sure that you didn’t mess up with the types of the columns in the database? blank stare

nway, i hope that my experience would help someone here!  grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top