Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Shipping not working after 1.5 -> 1.7 SSH upgrade
 
ryangingo
Jr. Member
 
Total Posts:  3
Joined:  2011-05-26
 

Hi everyone, I have quite a few items on a Magento store which was running a 1.5 fresh install. We use FedEx for shipping, and it recently stopped working. I was told that FedEx no longer supported 1.5 so I ran the following commands in the Magento root to upgrade to 1.7

find . -type f -exec chmod 777 {} \;
find . -type d -exec chmod 777 {} \;
rm -rf var/cache/* var/session/*
chmod 550 ./mage
./mage mage-setup .
./mage config-set preferred_state stable
./mage list-installed
./mage list-upgrades
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
php shell/indexer.php reindexall
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

Now everything states that it is fully upgraded when I list the installed modules and possible upgrades (there are none). However, the shipping problem is still not fixed. I have entered all 4 required elements into the FedEx module and it still gives me problems. In addition, I am now seeing this for every session in the debug log…

a:5:{i:0;s:211:"Error in file: “/home/blah/public_html/app/code/core/Mage/Sales/sql/sales_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php” - Column “base_shipping_hidden_tax_amount” does not exists on table “sales_flat_creditmemo"";i:1;s:988:"#0 /home/blah/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/blah/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘1.4.0.25’, ‘1.6.0.7’)
#2 /home/blah/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’1.4.0.25’, ‘1.6.0.7’)
#3 /home/blah/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/blah/public_html/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/blah/public_html/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /home/blah/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /home/blah/public_html/index.php(87): Mage::run(’’, ‘store’)
#8 {main}”;s:3:"url”;s:191:"/catalog/product_compare/add/product/646/uenc/aHR0cHM6Ly93d3cudXNhY29mZmVlbWFrZXIuY29tOjQ0My9uZXdjby9jb2ZmZWUtc2VydmVycy10ZWEtZGlzcGVuc2Vycy90ZWEtZGlzcGVuc2Vycy5odG1sP19fX3N0b3JlPWRlZmF1bHQ,/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:7:"default";}

Honestly, I have no idea what is going on… to my untrained eye it looks like a failed upgrade. Could anyone please help?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top