Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Sage Payment Problem.. would love some help! 
 
brainstormuk
Jr. Member
 
Total Posts:  4
Joined:  2011-12-12
 

Hi

I have a worrying problem on a clients site that I am looking into and I am wondering if their is a kind soul out there that can help.
The site has just moved to a new server and now when users try to order they get the below message:

Your payment failed
Order #100004496
There was an error with your payment. Please try again.
Please continue shopping.

There are no error logs on the site that indicate a problem with the website or the payment gateway loading.

So.. I contacted Sage support who said:

I have checked your account and can see that alot of payments are failing due to timeouts on the payment pages (customers closing their browser windows are the most common cause of this). The second reason for failures is an invalid or error response to our status notification post, this message comes from your website and if we do not receive an “OK” message in reply to our status notification post we will fail the transaction. This is explained in more detail in the attached guide on page 16.

I think this can be removed from the equation:
(customers closing their browser windows are the most common cause of this).

So that leads me to the 2nd part…

Does anyone know if this is an easy fix?  As I am helpless due to the fact my programmer who was dealing with this has now gone on holiday and the client needs this fixed.. like yesterday!

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
smg1965
Jr. Member
 
Total Posts:  24
Joined:  2009-03-30
 

What version of Magento are you on?
Are these Credit/Debit card failures or PayPal?
Are you using a payment extension, ebizmarts for example?

 
Magento Community Magento Community
Magento Community
Magento Community
 
brainstormuk
Jr. Member
 
Total Posts:  4
Joined:  2011-12-12
 
smg1965 - 01 June 2012 05:19 AM

What version of Magento are you on?
Are these Credit/Debit card failures or PayPal?
Are you using a payment extension, ebizmarts for example?

Hi

It’s Magento ver. 1.3.2.3

It’s credit/debit card processing.

I do not think we are using ebizmarts, there is no ebizmarts section in the configuration page.. but as i say, my programmer was dealing with this and he is the magento expert.

So I am trying to pick up the pieces...There is “Sage Pay” settings in the left hand side menu of config page.. that is all I can see

Would appreciate any help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
smg1965
Jr. Member
 
Total Posts:  24
Joined:  2009-03-30
 

I have had similar problems and what fixed/minimised the problem, which seems to be an issue of speed, is to implement the fix in the link below if applicable.

http://kassner.com.br/2011/01/magento-slow/

Also a faster server and cleaning out Magento logs will help.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top