Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento with subdomain can not login after upgraded
 
Ryan Sun _Kuafu
Guru
 
Total Posts:  317
Joined:  2008-11-14
FL
 

I have a magento setup with sub domain in developing environment, after upgraded from 1.4.2 to 1.7.0, I can not login admin,
to people who ist want to know how to fix it,
I just changed config value web/cookie/cookie_domain from ‘.sub.domain.com’ to ‘sub.domain.com’, I deleted the fist dot
to people who want to know why it fixed the login
check the code in Mage_Core_Model_Session_Abstract::renewSession(), a sub domain starting with dot would fall in the second if and get cookie deleted after session regenerated

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidsmith90
Member
 
Avatar
Total Posts:  37
Joined:  2011-10-12
 

I’ve seen this problem before, try the following settings in core_config_data table in your database:

web/cookie/cookie_lifetime  =  86400
web
/cookie/cookie_path leave blank
web
/cookie/cookie_domain  =  leave blank

See attached screenshot to see how it should look.

Let me know if this doesn’t work for you.

Image Attachments
Screen Shot 2012-06-01 at 10.41.17.png
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top