Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Novo Módulo Boleto Bancário p/ todos os Bancos, 2ª via Cliente e Admin, Link do boleto por email - Gratuito
 
fplamorim
Jr. Member
 
Total Posts:  7
Joined:  2009-03-29
 

Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
fplamorim - 21 February 2013 07:01 AM

Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

Fernando,
O que tenho aqui em localhost e que utilizo para todos os testes é o Magento 1.7.1, infelizmente ainda não tive como atualizar para a versão 1.7.2, porém acredito que funcionamento não deva ser tão diferente.
Tela toda branca, sem sinal de erro, pode ser várias coisas, até nem relacionada a esse módulo, veja se ativa no seu php as opções para mostrar os erros para ficar mais fácil tentar identificar de onde vem o problema.
Realmente não sei o que pode ter ocorrido, se algum colega com maior conhecimento conseguir dar uma ajuda de alguma forma seria bom.
A única coisa que posso te dizer é que uma vez tive um problema semelhante, pois apaguei os arquivos de um outro módulo de pagamentos que havia instalado e não gostei, porém aquele módulo havia ficado habilitado em sua opções, fui realizando vários testes com outro módulos sem nenhum problema, até que ativei a compilação e o erro apareceu, falando que aquele módulo de pagamento não estava ativo e etc, verifique se não pode ter ocorrido algo semelhante.

Boa sorte!

 
Magento Community Magento Community
Magento Community
Magento Community
 
traycheckout
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2013-01-16
 

Segue uma ótima opção de pagamento que conta com boleto bancário:
http://www.magentocommerce.com/boards/viewthread/316743/

Abs.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
ifredi - 18 March 2013 08:44 AM

Segue uma ótima opção de pagamento que conta com boleto bancário:
http://www.magentocommerce.com/boards/viewthread/316743/

Abs.

Para quem deseja utilizar Intermediadores de pagamentos para recebimentos de boletos, temos várias outras opções no mercado de empresas muito bem conceituadas, para quem desejar, segue algumas sugestões como:

www.pagseguro.com.br
www.bcash.com.br
www.moip.com.br
www.mercadopago.com.br

Único detalhe a citar é que a maioria das empresas cobram de 1,89% a 4,99% sobre a venda + taxa sobre a transação, fora 14 dias para receber o dinheiro, fora algumas que cobram taxa para saque.

Mas como o mérito do tópico não é discutir sobre intermediadores de pagamento e sim de justamente termos uma opção para fugirmos deles pelo menos no recebimento via boleto, vamos continuar no assunto principal....

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 

Pessoal,

O amigo Renato estava enfrentando um problema com o boleto Santander no Magento 1.7.2 , no local do de Agência/ Código do Cedente, ao invés de aparecer os números estava aparecendo “.$tmp2 ?>, nos outros bancos estava tudo ok e apenas nessa parte do boleto Santander estava dando problema.

Então observei que os desenvolvedores do Boleto PHP, no caso do boleto santander por exemplo, apenas nessa parte que é necessário códigos diferentes dos outros boletos, que é o código PSK e o código do ponto de venda, o pessoal fez com tag simples <? e ?>, então quem está com a opção short tags do PHP desativada, pode enfrentar esse tipo de problema, então a solução é ativar a função Short Tags no seu PHP ou se preferir verifique nos arquivos de layout : skin\boletophp\include o arquivo layout_nomedoseubanco.php onde tiver com tag simples <? , altere para <?php e resolverá o problema.

Então tem gente utilizando no Magento 1.7.2 com sucesso também.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fplamorim
Jr. Member
 
Total Posts:  7
Joined:  2009-03-29
 
rfln - 17 March 2013 09:48 AM

fplamorim - 21 February 2013 07:01 AM
Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

Fernando,
O que tenho aqui em localhost e que utilizo para todos os testes é o Magento 1.7.1, infelizmente ainda não tive como atualizar para a versão 1.7.2, porém acredito que funcionamento não deva ser tão diferente.
Tela toda branca, sem sinal de erro, pode ser várias coisas, até nem relacionada a esse módulo, veja se ativa no seu php as opções para mostrar os erros para ficar mais fácil tentar identificar de onde vem o problema.
Realmente não sei o que pode ter ocorrido, se algum colega com maior conhecimento conseguir dar uma ajuda de alguma forma seria bom.
A única coisa que posso te dizer é que uma vez tive um problema semelhante, pois apaguei os arquivos de um outro módulo de pagamentos que havia instalado e não gostei, porém aquele módulo havia ficado habilitado em sua opções, fui realizando vários testes com outro módulos sem nenhum problema, até que ativei a compilação e o erro apareceu, falando que aquele módulo de pagamento não estava ativo e etc, verifique se não pode ter ocorrido algo semelhante.

Boa sorte!

Consegui arrumar em parte… o arquivo Boleto.php estava com o “B” minusculo dai dava este erro quando não estava compilado… agora sem estar com o compilador ligado posso utilizar a área administrativa dos metodos de pagamento e ainda assim estar funcionando o Boleto no Site!!!

Att

 
Magento Community Magento Community
Magento Community
Magento Community
 
fplamorim
Jr. Member
 
Total Posts:  7
Joined:  2009-03-29
 

Boa Tarde,

Maravilha… agora está funcionando em ambos meus websites… porém tenho um problema… um dos sites utilizo HSBC e funciona perfeitamente… no outro utilizo a CAIXA com o SIGCB… e este está me dando problemas…

A CAIXA para homologar o boleto exige que o campo “VALOR DO DOCUMENTO” que fica ao lado do campo “QUANTIDADE” na fixa de compensação (a parte de baixo do boleto) esteja em branco… nesta área tem dois campos Valor do Documento, um tem o sinal de “=” antes… o que tem o sinal de “=” deve constar o valor a ser pago, o campo sem o sinal de = deve estar em BRANCO…

Alguem sabe como deixo em branco esta área?

Att

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
fplamorim - 21 March 2013 09:45 AM

rfln - 17 March 2013 09:48 AM
fplamorim - 21 February 2013 07:01 AM
Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

Fernando,
O que tenho aqui em localhost e que utilizo para todos os testes é o Magento 1.7.1, infelizmente ainda não tive como atualizar para a versão 1.7.2, porém acredito que funcionamento não deva ser tão diferente.
Tela toda branca, sem sinal de erro, pode ser várias coisas, até nem relacionada a esse módulo, veja se ativa no seu php as opções para mostrar os erros para ficar mais fácil tentar identificar de onde vem o problema.
Realmente não sei o que pode ter ocorrido, se algum colega com maior conhecimento conseguir dar uma ajuda de alguma forma seria bom.
A única coisa que posso te dizer é que uma vez tive um problema semelhante, pois apaguei os arquivos de um outro módulo de pagamentos que havia instalado e não gostei, porém aquele módulo havia ficado habilitado em sua opções, fui realizando vários testes com outro módulos sem nenhum problema, até que ativei a compilação e o erro apareceu, falando que aquele módulo de pagamento não estava ativo e etc, verifique se não pode ter ocorrido algo semelhante.

Boa sorte!

Consegui arrumar em parte… o arquivo Boleto.php estava com o “B” minusculo dai dava este erro quando não estava compilado… agora sem estar com o compilador ligado posso utilizar a área administrativa dos metodos de pagamento e ainda assim estar funcionando o Boleto no Site!!!

Att

Você alterou o nome da pasta skin/boletophp para skin/Boletophp, com o “B” maiúsculo e resolveu o problema de ligar a compilação ai pra você, foi isso?....Porque o único lugar que tem o nome boletophp é a pasta skin/boletophp, não achei outro local.

Se foi isso, fica a dica para quem está tendo o mesmo problema, assim que eu tiver um tempo vou dar uma verificada com mais calma nessa questão de as vezes algum arquivo com maiuscula ou minuscula estar causando esse problema, o estranho que pelo que eu vi por aqui em nenhum momento dos arquivos de configuração está mencionado nada a Boletophp com o “B” maiusculo, tudo que observei está mencionado com ele com o “B” minusculo, por isso acho estranho isso causar algum tipo de problema.

De qualquer forma ressalto mais uma vez que utilizo o módulo para testes em uma versão limpa do Magento e consigo utilizar tanto com a compilcação ativada ou desativada sem nenhum problema, esse parte realmente pelo meu pouco conhecimento em Magento não consegui decifrar o porque funciona perfeitamente para alguns e não funciona para outros.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
fplamorim - 21 March 2013 09:49 AM

Boa Tarde,

Maravilha… agora está funcionando em ambos meus websites… porém tenho um problema… um dos sites utilizo HSBC e funciona perfeitamente… no outro utilizo a CAIXA com o SIGCB… e este está me dando problemas…

A CAIXA para homologar o boleto exige que o campo “VALOR DO DOCUMENTO” que fica ao lado do campo “QUANTIDADE” na fixa de compensação (a parte de baixo do boleto) esteja em branco… nesta área tem dois campos Valor do Documento, um tem o sinal de “=” antes… o que tem o sinal de “=” deve constar o valor a ser pago, o campo sem o sinal de = deve estar em BRANCO…

Alguem sabe como deixo em branco esta área?

Att

Ai já entra no mérito do trabalho do grupo boleto php, se eu não me engano eles só publicam o boleto depois de conseguir a homologação e estar tudo nos conformes conforme exigência do banco, pelo que pude perceber e isso realmente acontece, acho que tem cara que na hora de homologar é mais casca de ferida e fica querendo arrumar cabelo em ovo pra dificultar, já teve colegas que teve problema pra homologação junto ao santander sendo que o meu foi homologado de primeira e sem problemas, se o módulo é o mesmo e o boleto é o mesmo então qual a diferença?...realmente alguém querendo encher o saco.

Mas no seu caso é fácil, edite no arquivo skin\boletophp\include\layout_cef_sigcb.php , que o responsável pelo layout citado e procure pela parte que deseja que fique em branco e retire a variável que manda o valor do boleto pra lá.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Carlos Zamora
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2010-04-26
 
rfln - 18 April 2013 05:00 AM

fplamorim - 21 March 2013 09:45 AM
rfln - 17 March 2013 09:48 AM
fplamorim - 21 February 2013 07:01 AM
Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

Fernando,
O que tenho aqui em localhost e que utilizo para todos os testes é o Magento 1.7.1, infelizmente ainda não tive como atualizar para a versão 1.7.2, porém acredito que funcionamento não deva ser tão diferente.
Tela toda branca, sem sinal de erro, pode ser várias coisas, até nem relacionada a esse módulo, veja se ativa no seu php as opções para mostrar os erros para ficar mais fácil tentar identificar de onde vem o problema.
Realmente não sei o que pode ter ocorrido, se algum colega com maior conhecimento conseguir dar uma ajuda de alguma forma seria bom.
A única coisa que posso te dizer é que uma vez tive um problema semelhante, pois apaguei os arquivos de um outro módulo de pagamentos que havia instalado e não gostei, porém aquele módulo havia ficado habilitado em sua opções, fui realizando vários testes com outro módulos sem nenhum problema, até que ativei a compilação e o erro apareceu, falando que aquele módulo de pagamento não estava ativo e etc, verifique se não pode ter ocorrido algo semelhante.

Boa sorte!

Consegui arrumar em parte… o arquivo Boleto.php estava com o “B” minusculo dai dava este erro quando não estava compilado… agora sem estar com o compilador ligado posso utilizar a área administrativa dos metodos de pagamento e ainda assim estar funcionando o Boleto no Site!!!

Att

Você alterou o nome da pasta skin/boletophp para skin/Boletophp, com o “B” maiúsculo e resolveu o problema de ligar a compilação ai pra você, foi isso?....Porque o único lugar que tem o nome boletophp é a pasta skin/boletophp, não achei outro local.

Se foi isso, fica a dica para quem está tendo o mesmo problema, assim que eu tiver um tempo vou dar uma verificada com mais calma nessa questão de as vezes algum arquivo com maiuscula ou minuscula estar causando esse problema, o estranho que pelo que eu vi por aqui em nenhum momento dos arquivos de configuração está mencionado nada a Boletophp com o “B” maiusculo, tudo que observei está mencionado com ele com o “B” minusculo, por isso acho estranho isso causar algum tipo de problema.

De qualquer forma ressalto mais uma vez que utilizo o módulo para testes em uma versão limpa do Magento e consigo utilizar tanto com a compilcação ativada ou desativada sem nenhum problema, esse parte realmente pelo meu pouco conhecimento em Magento não consegui decifrar o porque funciona perfeitamente para alguns e não funciona para outros.

Pessoal, só complementando o que o amigo fplamorim recomendou, o arquivo é banco.php (devendo mudar o B para maiúsculo). Eu também estava com ‘boleto’ na cabeça e não conseguia encontrar o problema!

O banco.php do:

app/code/community/RafaelCamargo/Boleto/Model

Aqui corrigiu e estou editando os módulos sem problemas com o compilador desabilitado. Obrigado Rafael / Fernando.

PS: Rafael, parabéns pelo módulo, realmente muito bem produzido e documentado. Gostaria de questioná-lo se há algum meio de fazer uma doação - pequena, mas de coração!

Obrigado!

 
Magento Community Magento Community
Magento Community
Magento Community
 
malimpense
Jr. Member
 
Total Posts:  1
Joined:  2012-09-12
 

Senhores, bom dia à todos.

Recentemente instalei em minha loja o módulo de boleto bancário Cushy (do Deivison + Rafael Camargo) e tudo funciona muito bem. Exceto por uma coisa, quando eu rodo a compilação e habilito a mesma, o módulo para. Não aparece mais no front nas formas de pagamento e daí não consigo visualizar os pedidos que foram feitos com a forma de pagamento do módulo.

Alguém sabe o que pode ser isso? O módulo não deveria trabalhar com o compiler habilitado?

O erro que aparece quando tento visualizar um pedido com o compiler habilitado é Exception printing is disabled by default for security reasons.
Error log record number: 851904484651

O log:

----------------------------------------------------
a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:4832:"#0 /home/leoneloc/public_html/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)
#1 /home/leoneloc/public_html/includes/src/Mage_Payment_Helper_Data.php(119): Mage_Payment_Model_Info->getMethodInstance()
#2 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Sales_Order_Payment.php(50): Mage_Payment_Helper_Data->getInfoBlock(Object(Mage_Sales_Model_Order_Payment))
#3 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Sales_Order_Payment.php(44): Mage_Adminhtml_Block_Sales_Order_Payment->setPayment(Object(Mage_Sales_Model_Order_Payment))
#4 /home/leoneloc/public_html/includes/src/__default.php(2517): Mage_Adminhtml_Block_Sales_Order_Payment->_beforeToHtml()
#5 /home/leoneloc/public_html/includes/src/__default.php(2237): Mage_Core_Block_Abstract->toHtml()
#6 /home/leoneloc/public_html/includes/src/__default.php(2181): Mage_Core_Block_Abstract->_getChildHtml(’order_payment’, true)
#7 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Sales_Order_View_Tab_Info.php(112): Mage_Core_Block_Abstract->getChildHtml(’order_payment’)
#8 /home/leoneloc/public_html/app/design/adminhtml/default/default/template/onepagecheckout/info.phtml(45): Mage_Adminhtml_Block_Sales_Order_View_Tab_Info->getPaymentHtml()
#9 /home/leoneloc/public_html/includes/src/__default.php(3223): include(’/home/leoneloc/...’)
#10 /home/leoneloc/public_html/includes/src/__default.php(3254): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#11 /home/leoneloc/public_html/includes/src/__default.php(3268): Mage_Core_Block_Template->renderView()
#12 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Template.php(81): Mage_Core_Block_Template->_toHtml()
#13 /home/leoneloc/public_html/includes/src/__default.php(2518): Mage_Adminhtml_Block_Template->_toHtml()
#14 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Widget_Tabs.php(303): Mage_Core_Block_Abstract->toHtml()
#15 /home/leoneloc/public_html/app/design/adminhtml/default/default/template/widget/tabs.phtml(38): Mage_Adminhtml_Block_Widget_Tabs->getTabContent(Object(Mage_Adminhtml_Block_Sales_Order_View_Tab_Info))
#16 /home/leoneloc/public_html/includes/src/__default.php(3223): include(’/home/leoneloc/...’)
#17 /home/leoneloc/public_html/includes/src/__default.php(3254): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#18 /home/leoneloc/public_html/includes/src/__default.php(3268): Mage_Core_Block_Template->renderView()
#19 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Template.php(81): Mage_Core_Block_Template->_toHtml()
#20 /home/leoneloc/public_html/includes/src/__default.php(2518): Mage_Adminhtml_Block_Template->_toHtml()
#21 /home/leoneloc/public_html/includes/src/__default.php(13160): Mage_Core_Block_Abstract->toHtml()
#22 /home/leoneloc/public_html/includes/src/__default.php(2518): Mage_Core_Block_Text_List->_toHtml()
#23 /home/leoneloc/public_html/includes/src/__default.php(2237): Mage_Core_Block_Abstract->toHtml()
#24 /home/leoneloc/public_html/includes/src/__default.php(2181): Mage_Core_Block_Abstract->_getChildHtml(’left’, true)
#25 /home/leoneloc/public_html/app/design/adminhtml/default/default/template/page.phtml(58): Mage_Core_Block_Abstract->getChildHtml(’left’)
#26 /home/leoneloc/public_html/includes/src/__default.php(3223): include(’/home/leoneloc/...’)
#27 /home/leoneloc/public_html/includes/src/__default.php(3254): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#28 /home/leoneloc/public_html/includes/src/__default.php(3268): Mage_Core_Block_Template->renderView()
#29 /home/leoneloc/public_html/includes/src/Mage_Adminhtml_Block_Template.php(81): Mage_Core_Block_Template->_toHtml()
#30 /home/leoneloc/public_html/includes/src/__default.php(2518): Mage_Adminhtml_Block_Template->_toHtml()
#31 /home/leoneloc/public_html/includes/src/__default.php(27393): Mage_Core_Block_Abstract->toHtml()
#32 /home/leoneloc/public_html/includes/src/__default.php(13553): Mage_Core_Model_Layout->getOutput()
#33 /home/leoneloc/public_html/app/code/core/Mage/Adminhtml/controllers/Sales/OrderController.php(119): Mage_Core_Controller_Varien_Action->renderLayout()
#34 /home/leoneloc/public_html/includes/src/__default.php(13582): Mage_Adminhtml_Sales_OrderController->viewAction()
#35 /home/leoneloc/public_html/includes/src/__default.php(17927): Mage_Core_Controller_Varien_Action->dispatch(’view’)
#36 /home/leoneloc/public_html/includes/src/__default.php(17484): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#37 /home/leoneloc/public_html/includes/src/__default.php(20061): Mage_Core_Controller_Varien_Front->dispatch()
#38 /home/leoneloc/public_html/app/Mage.php(698): Mage_Core_Model_App->run(Array)
#39 /home/leoneloc/public_html/index.php(87): Mage::run(’’, ‘store’)
#40 {main}”;s:3:"url”;s:46:"/index.php/admin/sales_order/view/order_id/70/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:5:"admin";}

E aí, alguma luz?

Diogo Malimpense

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
Carlos Zamora - 04 June 2013 11:34 AM

rfln - 18 April 2013 05:00 AM
fplamorim - 21 March 2013 09:45 AM
rfln - 17 March 2013 09:48 AM
fplamorim - 21 February 2013 07:01 AM
Primeiramente gostaria de parabenizar e agradecer pelo módulo. Venho utilizando à mais de 6 meses, porém tinha encontrado no blog do Deivison, mas após ver aqui o que teria acontecido comecei a utilizar a cópia daqui.

Meu problema:

Tenho utilizado em um de meus sites com sucesso todo este tempo (Magento 1.6.2.0), porém agora estou configurando um novo site (Magento 1.7.0.2) e estou tendo aquele problema com a Tela Branca ou Erro no Metodos de Pagamento.

Com o Compilador DESLIGADO eu consigo visualisar no site o metodo de pagamento, fazer pedidos, e gerar segunda via no Admin ou no Painel do Usuário, porém não consigo visualizar METODOS DE PAGAMENTO na configuração. Não me dá o erro indicado aqui, somente fica uma tela branca.

Com o Compilador LIGADO eu consigo visualizar o METODOS DE PAGAMENTO, e fazer as alterações lá necessárias, porém não aparece a opção de Boleto no Frontend e nos pedidos gerados previamente com Boleto aparece o erro :

a:5:{i:0;s:46:"The requested Payment Method is not available.";i:1;s:5416:"#0 /var/www/vhosts/MEUDOMINIO.com.br/httpdocs/includes/src/Mage_Payment_Model_Info.php(82): Mage::throwException(’The requested P...’)

Ok… sei que posso ligar o Compilador e editar o metodo e depois desligar o compilador e utilizar o site… um outro detalhe é que estou utilizando um modulo ONEPAGECHECKOUT feito para o Brasil (da O2TI), o qual eu tive que editar o “info.phtml” para poder ver os Links de 2a Via do Boleto, pois este modulo tem seu próprio arquivo “info.phtml” e alterando somente o normal não aparecia na área administrativa o Link.

Espero não ter sido muito confuso. Agradeço toda e qualquer ajuda!

Obs.: Eu fiz todos os passos de Cache, etc…

Atenciosamente

Fernando Amorim

Fernando,
O que tenho aqui em localhost e que utilizo para todos os testes é o Magento 1.7.1, infelizmente ainda não tive como atualizar para a versão 1.7.2, porém acredito que funcionamento não deva ser tão diferente.
Tela toda branca, sem sinal de erro, pode ser várias coisas, até nem relacionada a esse módulo, veja se ativa no seu php as opções para mostrar os erros para ficar mais fácil tentar identificar de onde vem o problema.
Realmente não sei o que pode ter ocorrido, se algum colega com maior conhecimento conseguir dar uma ajuda de alguma forma seria bom.
A única coisa que posso te dizer é que uma vez tive um problema semelhante, pois apaguei os arquivos de um outro módulo de pagamentos que havia instalado e não gostei, porém aquele módulo havia ficado habilitado em sua opções, fui realizando vários testes com outro módulos sem nenhum problema, até que ativei a compilação e o erro apareceu, falando que aquele módulo de pagamento não estava ativo e etc, verifique se não pode ter ocorrido algo semelhante.

Boa sorte!

Consegui arrumar em parte… o arquivo Boleto.php estava com o “B” minusculo dai dava este erro quando não estava compilado… agora sem estar com o compilador ligado posso utilizar a área administrativa dos metodos de pagamento e ainda assim estar funcionando o Boleto no Site!!!

Att

Você alterou o nome da pasta skin/boletophp para skin/Boletophp, com o “B” maiúsculo e resolveu o problema de ligar a compilação ai pra você, foi isso?....Porque o único lugar que tem o nome boletophp é a pasta skin/boletophp, não achei outro local.

Se foi isso, fica a dica para quem está tendo o mesmo problema, assim que eu tiver um tempo vou dar uma verificada com mais calma nessa questão de as vezes algum arquivo com maiuscula ou minuscula estar causando esse problema, o estranho que pelo que eu vi por aqui em nenhum momento dos arquivos de configuração está mencionado nada a Boletophp com o “B” maiusculo, tudo que observei está mencionado com ele com o “B” minusculo, por isso acho estranho isso causar algum tipo de problema.

De qualquer forma ressalto mais uma vez que utilizo o módulo para testes em uma versão limpa do Magento e consigo utilizar tanto com a compilcação ativada ou desativada sem nenhum problema, esse parte realmente pelo meu pouco conhecimento em Magento não consegui decifrar o porque funciona perfeitamente para alguns e não funciona para outros.

Pessoal, só complementando o que o amigo fplamorim recomendou, o arquivo é banco.php (devendo mudar o B para maiúsculo). Eu também estava com ‘boleto’ na cabeça e não conseguia encontrar o problema!

O banco.php do:

app/code/community/RafaelCamargo/Boleto/Model

Aqui corrigiu e estou editando os módulos sem problemas com o compilador desabilitado. Obrigado Rafael / Fernando.

PS: Rafael, parabéns pelo módulo, realmente muito bem produzido e documentado. Gostaria de questioná-lo se há algum meio de fazer uma doação - pequena, mas de coração!

Obrigado!

Ótima observação Zamora, então quem estiver tendo o problema dele funcionar com a compilação ativada é só seguir a dica acima do amigo Zamora, infelizmente estou sem como efetuar testes pois até hoje minha loja Magento não saiu do papel e como formatei meu pc recentemente ainda não reinstalei pra continuar da onde parei...rsrsrs

Zamora, quanto ao seu questionamento, nas instruções de instalação, na última parte disponibilizei um botão de doação através do Pagseguro para quem de alguma forma quiser fazer qualquer tipo de doação.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 

********************ATUALIZADO 06/11/2013***************************
- Problema de desligar compilação resolvido. Alterado o nome do arquivo “banco.php” para “Banco.php”, no caminho: app/code/community/RafaelCamargo/Boleto/Model , o “b” minúsculo causava o problema (obrigado aos amigos: fplamorim e Carlos Zamora).

Faça o download no inicio do tópico

 
Magento Community Magento Community
Magento Community
Magento Community
 
MSHostBrasil
Jr. Member
 
Total Posts:  2
Joined:  2013-06-18
 

Boa noite a todos,
Instalei e ele está funcionando, só que um problema.

Obs¹: tentei pagar o boleto digitando o código de barras...o valor que debitaria da minha conta apareceu correto (23,89)...daí dei o enter pra pagar....voltou a seguinte mensagem:
***DV COD-BARRAS INVALIDO (ERRO G441-561)***
Deu esse erro e não consegui finalizar o pagamento…

Obs²: fui pagar esse boleto através do meu celular e quando passei o leitor no código de barras acusou um pagamento no valor de 238,90 e não 23,89 como consta no boleto. Daí, pra tirar a dúvida entrei no banco através do meu computador e passei no leitor de código de barras desses de mesa...bicho....o leitor leu 50.000.002,38 (cinquenta milhões, dois reais e trinta e oito centavos).

Link para imagem: http://img21.imageshack.us/img21/9431/ssc5.png

Olhem a imagem e irão entender.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rfln
Member
 
Total Posts:  42
Joined:  2012-05-14
 
MSHostBrasil - 14 November 2013 03:22 PM

Boa noite a todos,
Instalei e ele está funcionando, só que um problema.


Obs¹: tentei pagar o boleto digitando o código de barras...o valor que debitaria da minha conta apareceu correto (23,89)...daí dei o enter pra pagar....voltou a seguinte mensagem:
***DV COD-BARRAS INVALIDO (ERRO G441-561)***
Deu esse erro e não consegui finalizar o pagamento…


Obs²: fui pagar esse boleto através do meu celular e quando passei o leitor no código de barras acusou um pagamento no valor de 238,90 e não 23,89 como consta no boleto. Daí, pra tirar a dúvida entrei no banco através do meu computador e passei no leitor de código de barras desses de mesa...bicho....o leitor leu 50.000.002,38 (cinquenta milhões, dois reais e trinta e oito centavos).

Link para imagem: http://img21.imageshack.us/img21/9431/ssc5.png

Olhem a imagem e irão entender.

MSHostBrasil, por todos testes que fiz durante o desenvolvimento, acredito que esse problema possa estar relacionado apenas a questão das configurações das informações do banco no admin do módulo, verifique com calma se não está faltando ou sobrando nenhum número, digito verificador da agência onde tem que estar, número da carteira e etc.....erro muito comum do pessoal é colocar o digito verificador junto ao número da conta ou da agência, ai sempre causa erro.

Agora em relação ao código de barras, existe várias variáveis que pode fazer ocorrer o erro, já foi informado por outros amigos que o IE tem problema no momento do processamento do código de barras, a utilização de algum programa que transforma o boleto em pdf pode alterar essa parte, desde a própria qualidade da impressão em si...pois independente do problema, era para os 2 leitores apresentarem o mesmo código de barras, nem que o código estive incorreto.

Sugiro que primeiro veja com calma a questão das configurações das informações do banco no admin e faça os teste apenas com o número, depois que tiver tudo ok ai você reve com calma a questão do código de barras, lembrando que já tem relatos de outros usuários que estão utilizando com o itaú sem problemas.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top