Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cannot Access Connect Manager (or Manage Extensions) tAfter Upgrade from clean 1.1.6 to clean 1.2.0.1
 
NetWorX
Jr. Member
 
Total Posts:  3
Joined:  2008-11-05
 

After Upgrade from clean 1.1.6 to clean 1.2.0.1 (no products yet & also other probs resolved ) can log into Admin Panel OK, BUT when accessing ConnectMgr now (or manage extensions) get the following error
(NOTE: Connect Managerinterface worked prior to & for upgrade to 1.2.0.1 via insert of “magento-core/Mage_All_Latest in the extension key field & click install + ALL permissions changed to “777” for All files & folders ) :

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/domains/store.cleanol.com/docs/shopping/downloader/pearlib/php/System.php:459) in /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 95
Trace:
#0 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(95): mageCoreErrorHandler(2, ‘session_start()...’, ‘/var/www/domain...’, 95, Array)
#1 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(129): Mage_Core_Model_Session_Abstract_Varien->start()
#2 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Session/Abstract.php(53): Mage_Core_Model_Session_Abstract_Varien->init(’adminhtml’)
#3 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Session.php(39): Mage_Core_Model_Session_Abstract->init(’core’, ‘adminhtml’)
#4 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Model/Config.php(790): Mage_Core_Model_Session->__construct(’core’, ‘adminhtml’)
#5 /var/www/domains/store.cleanol.com/docs/shopping/app/Mage.php(317): Mage_Core_Model_Config->getModelInstance(Array)
#6 /var/www/domains/store.cleanol.com/docs/shopping/app/Mage.php(331): Mage::getModel(’core/session’, Array)
#7 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Controller/Varien/Action.php(379): Mage::getSingleton(’core/session’, Array)
#8 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Adminhtml/Controller/Action.php(131): Mage_Core_Controller_Varien_Action->preDispatch(’core/session’, Array)
#9 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Controller/Varien/Action.php(341): Mage_Adminhtml_Controller_Action->preDispatch()
#10 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(143): Mage_Core_Controller_Varien_Action->dispatch()
#11 /var/www/domains/store.cleanol.com/docs/shopping/app/code/core/Mage/Core/Controller/Varien/Front.php(174): Mage_Core_Controller_Varien_Router_Admin->match(’index’)
#12 /var/www/domains/store.cleanol.com/docs/shopping/app/Mage.php(450): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#13 /var/www/domains/store.cleanol.com/docs/shopping/index.php(52): Mage::run()
#14 {main}

Assistance, advise & Help! please! Tahn you in advance…

File Attachments
Events&Errors(01-10-2009)a.txt  (File Size: 3KB - Downloads: 362)
 
Magento Community Magento Community
Magento Community
Magento Community
 
haleann
Jr. Member
 
Total Posts:  2
Joined:  2008-09-25
 

if you cannot access magento connect, or get a error, log into your websites cpanel area, if your not sure what this is, you got it when you signed up for your domain name, or ask web hosting.

after this, go to

public_html>downloader

and chmod index.php file to 644

you simply cannot see the magento connect area becuase this file is writeable by group and it should not be.

jean

 
Magento Community Magento Community
Magento Community
Magento Community
 
zvezda
Jr. Member
 
Total Posts:  14
Joined:  2007-09-20
 

I have index.php set to 644 and still cannot use magento connect.
But I do not have access to SsH

so how can I use magento connect? any with some expirience?

thanks
z

 
Magento Community Magento Community
Magento Community
Magento Community
 
J.S. Coolen
Sr. Member
 
Total Posts:  86
Joined:  2009-08-20
Den Haag, Nederland
 

I cant open the magento connect either. I set the permissions to 644.

Where can I find php.ini? What are the right setting for my server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
unfeasible
Sr. Member
 
Avatar
Total Posts:  94
Joined:  2008-03-03
New Zealand
 

Does anyone have any resolve to this issue at all yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
luardo
Jr. Member
 
Total Posts:  1
Joined:  2012-04-12
 

@ haleann Brilliant it work. I changed the files permision to 644 and it worked out.
thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidrecinos
Jr. Member
 
Total Posts:  1
Joined:  2012-06-27
 

I had the same problem. I have not solved it, but when I try to go direct to the URL, it works.  I mean: mydomine.com/magento/downloader/
I don’t know why it works in this way, but not when I try to go from my Admin Panel.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jcalagaz
Jr. Member
 
Total Posts:  3
Joined:  2011-09-01
 

I am having the same issue and solved it by removing the last part of the url and only leaving the http://www.mysite.com/downloader/

removing the from ?return=https to the end of the bar. 

once I remove it it presents me with the connect log on page and I have been able to load extensions with out a problem.

hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top